Bug #84465

"Status report" broken because of invalid route

Added by Mathias Brodala over 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
-
Start date:
2018-03-18
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

The Status report within the Reports module throws an exception due to an invalid route identifier:

#1476050190: Unable to generate a URL for the named route "system_ReportsTxreportsm1" because this route was not found.


Related issues

Related to TYPO3 Core - Task #83172: Use BE Routing / PSR-7 instead of BackendUtility::getModuleUrl Closed 2017-11-29
Related to TYPO3 Core - Bug #84231: Remove usage of extbase from reports module Closed 2018-03-13

Associated revisions

Revision 05fe4221 (diff)
Added by Mathias Brodala over 1 year ago

[BUGFIX] Fix routing exception for "Status report" module

This fixes an error caused by the admin account status check which is
only executed for admin accounts with insecure passwords.

Change-Id: Ie81ee81ef61445397d6a062e285ebdbca2c5e6d7
Resolves: #84465
Releases: master
Reviewed-on: https://review.typo3.org/56347
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>
Reviewed-by: Łukasz Uznański <>
Reviewed-by: Andreas Wolf <>
Tested-by: Andreas Wolf <>

History

#1 Updated by Mathias Brodala over 1 year ago

  • Related to Task #83172: Use BE Routing / PSR-7 instead of BackendUtility::getModuleUrl added

#2 Updated by Mathias Brodala over 1 year ago

  • Related to Bug #84231: Remove usage of extbase from reports module added

#3 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56347

#4 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56347

#5 Updated by Mathias Brodala over 1 year ago

To reproduce this you need have an admin account:

  • name: admin
  • password: password

Anything else won't trigger this the admin account check.

#6 Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56347

#7 Updated by Mathias Brodala over 1 year ago

  • Status changed from Under Review to Resolved

#8 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF