Bug #84231

Remove usage of extbase from reports module

Added by Georg Ringer almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2018-03-13
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

to improve performance and less dependencies extbase is dropped from the reports module


Related issues

Related to TYPO3 Core - Bug #84465: "Status report" broken because of invalid route Closed 2018-03-18
Related to TYPO3 Core - Task #86184: Protect methods in ReportController Closed 2018-09-07
Related to TYPO3 Core - Bug #86318: Use module state of reports module Closed 2018-09-19

Associated revisions

Revision 0f722b53 (diff)
Added by Georg Ringer almost 2 years ago

[TASK] Remove dependency to extbase from reports module

Simplify the reports module by removing usage of extbase.

Resolves: #84231
Releases: master
Change-Id: I33d55e60b454b0945a7a98f7cafb15bfc69dc18d
Reviewed-on: https://review.typo3.org/56125
Tested-by: TYPO3com <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision f09ad89e (diff)
Added by Christian Kuhn over 1 year ago

[TASK] Protected methods in ReportController

There are only two methods in the report controller, calling
them via call_user_function() does not make much sense.
The patch simplifies the dispatcher logic and sets the two
actions to protected.
Note this does not affect the extendability of the reports
module itself.

Resolves: #86184
Related: #84231
Releases: master
Change-Id: Ia329b7de7251825028a5587899be3f6c694873e5
Reviewed-on: https://review.typo3.org/58214
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: rolandgolla <>
Tested-by: rolandgolla <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

Revision a471ed7c (diff)
Added by Christian Kuhn over 1 year ago

[BUGFIX] Use module state of reports module

The reports module stores its latest action selection in
backend user uc and should select that action on next
call again. This broke with the refactoring of #84231

Resolves: #86318
Related: #84231
Releases: master
Change-Id: If3cfe27361bcdc7b15c2f1cfaa34a8cc0c1e88c9
Reviewed-on: https://review.typo3.org/58336
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Tested-by: TYPO3com <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56125

#2 Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56125

#3 Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56125

#4 Updated by Gerrit Code Review almost 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56125

#5 Updated by Gerrit Code Review almost 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56125

#6 Updated by Gerrit Code Review almost 2 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56125

#7 Updated by Gerrit Code Review almost 2 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56125

#8 Updated by Gerrit Code Review almost 2 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56125

#9 Updated by Georg Ringer almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Mathias Brodala almost 2 years ago

  • Related to Bug #84465: "Status report" broken because of invalid route added

#11 Updated by Christian Kuhn over 1 year ago

  • Related to Task #86184: Protect methods in ReportController added

#12 Updated by Christian Kuhn over 1 year ago

  • Related to Bug #86318: Use module state of reports module added

#13 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF