Project

General

Profile

Actions

Bug #84668

closed

Sites: Links for language menus are not generated correctly

Added by Benjamin Kott about 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2018-04-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If the language-base is pointing to a different domain the HMENU language does not generate correct links.

Actual behavioir:

- English => https://www.mydomain.com/en/
- German => https://www.mydomain.com/de/
- Dansk => https://www.mydomain.com/

Expected behavior:

- English => https://www.mydomain.com/en/
- German => https://www.mydomain.com/de/
- Dansk => https://www.mydomain.dk/

Example Configuration:

site:
  rootPageId: 1
  base: 'https://www.mydomain.com/'
  languages:
    -
      languageId: '0'
      title: English
      navigationTitle: English
      base: /en/
      locale: en_US.UTF8
      iso-639-1: en
      hreflang: en-US
      direction: ltr
      typo3Language: default
      flag: us
    -
      languageId: '2'
      title: German
      navigationTitle: Deutsch
      base: /de/
      locale: de_DE.UTF8
      iso-639-1: de
      hreflang: de-DE
      direction: rtl
      typo3Language: de
      flag: de
      fallbackType: strict
    -
      languageId: '1'
      title: Dansk
      navigationTitle: Dansk
      base: 'http://www.mydomain.dk/'
      locale: da_DK.UTF-8
      iso-639-1: da
      hreflang: da-DK
      direction: ltr
      typo3Language: da
      flag: dk
      fallbackType: strict
  errorHandling: {  }

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Epic #83796: Site HandlingClosedBenni Mack2015-08-09

Actions
Actions

Also available in: Atom PDF