Bug #85248

Show link in page tree context menu links to wrong domain for mount points

Added by Patrick Broens about 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2018-06-13
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:
On Location Sprint

Description

We have the current situation:

  • root 1 (domain1.com)
  • mount point 1 to mounted page (Show the mounted page)
  • root 2 (domain2.com)
  • mount point 2 to mounted page (Show the mounted page)
  • root 3 (domain3.com)
  • mounted page

When being in the page module, the "View webpage" button in the docheader of the page or "Save and View" in edit mode of the page goes to the right domain. So if you click on "View webpage" at the mount point within root 1, the page is shown within the right domain, with the right layout. The same goes for the "Web > View" module.

However, when clicking the "Show" link in the context menu of the page tree for the mount point within root 1, it will show the page within domain3.com, although with the mount point parameters in the url.

The problem is that the context menu record provider is not passing the rootline for a certain page to the method BackendUtility::viewOnClick() while for the other buttons this is passed to the same method.

History

#1 Updated by Tymoteusz Motylewski about 1 year ago

  • Sprint Focus set to On Location Sprint

#2 Updated by Nicolai Schirawski 10 months ago

I will try to fix it during sprint in Berlin

#3 Updated by Nicolai Schirawski 10 months ago

I tried to reproduce the bug, but couldn't using TYPO3 9.5.1-dev.

I installed 2 scenarios:
  • one with domain-configuration by the new modul "sites"
  • one with domain-configuration in the old way, using domain-records

In both cases all views, edit-buttons and context-menu-entries work as expected.

I assume that the bug might be fixed in the meantime.

@Patrik Broens: Could you please verifiy if the bug persists - and if yes, please provide detailed steps how to reproduce the bug.

#4 Updated by Anja Leichsenring 10 months ago

  • Status changed from New to Needs Feedback

#5 Updated by Patrick Broens 7 months ago

It seems the issue has been resolved. At least in current master I cannot reproduce this

#6 Updated by Patrick Broens 7 months ago

  • Status changed from Needs Feedback to Resolved

#7 Updated by Benni Mack 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF