Bug #85406

Related files in Text & Media do not get exported / imported correctly

Added by Sybille Peters over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Import/Export (T3D)
Target version:
-
Start date:
2018-06-27
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem

Import / Export does not work with Files attached to Text & Media

System environment

TYPO3 8.7.16

Reproduce

  1. create page with 1 Text & Media and 1 file attached
  2. Export it using default settings: "This page", all tables, etc.
  3. import it in a different installation (with default settings), do not force uids

Results

1. On exporting there are error messages for sys_file uid=76: LOST RELATION:

However, file with uid=76 exists and File is correctly linked to Text & Media as visible in the backend:

select uid,identifier from sys_file where uid=76;
+-----+--------------------------------+
| uid | identifier                     |
+-----+--------------------------------+
|  76 | /user_upload/no_file_found.png |
+-----+--------------------------------+

2. After importing, a wrong image is linked with the Text & Media

sys_file_reference shows that a new sys_file_reference record was created using the same uid_local as in the export installation. Of course, the uid_local=76 corresponds with a different file in this installation.

sys_file_reference
+-------+-----------+-------------+-------------+------------+
| uid   | uid_local | uid_foreign | table_local | tablenames |
+-------+-----------+-------------+-------------+------------+
| 67108 |        76 |      239506 | sys_file    | tt_content |
+-------+-----------+-------------+-------------+------------+

3. Testing this with another installation, the import did not work at all because an exception gets thrown:

Uncaught TYPO3 Exception
#1317178604: No file found for given UID: 207889

Apparently, for this uid, a corresponding sys_file record does not exist yet.

impexp2.png View (30 KB) Sybille Peters, 2018-06-27 15:00


Related issues

Related to TYPO3 Core - Bug #84041: Existing file references are modified after export/import Accepted 2018-02-26

History

#1 Updated by Sybille Peters over 1 year ago

  • Related to Bug #84041: Existing file references are modified after export/import added

#2 Updated by Sybille Peters over 1 year ago

  • File impexp.png added
  • Description updated (diff)

#3 Updated by Sybille Peters over 1 year ago

  • File deleted (impexp.png)

#4 Updated by Sybille Peters over 1 year ago

  • File deleted (impexp.png)

#5 Updated by Sybille Peters over 1 year ago

#6 Updated by Sybille Peters over 1 year ago

  • Subject changed from Linked files in Text & Media do not get exported / imported correctly to Related files in Text & Media do not get exported / imported correctly

#7 Updated by J. Peter M. Schuler over 1 year ago

Perhaps a clearification/question:
With default settings, you will loose all FAL files, because FAL files are not stored on the page, so you need to add “Include relations to table” and select sys_file* tables there, else all files should be lost by definition. Or am I understanding something wrong here?
That's the same reason why during import there will be a warning that the metadata will be written on root page, isn't it?

That is of course not intuitive and perhaps these defaults should be changed, but the behaviour seems to be in line with the options set.

#8 Updated by Sybille Peters over 1 year ago

  • Status changed from New to Closed

Thank you, Peter. That was most helpful.

It appears to have in fact been a user error. I am currently not sure, what went wrong, because I thought I did select the required tables. But, now I am getting a bunch of error messages about maxFileSize which can be dealt with. And the resulting .t3d is much bigger.

I seems several people are of the opinion that the usablity could be improved, but that is a different issue, so I will close this one.

#9 Updated by Sybille Peters over 1 year ago

  • Parent task deleted (#72584)

Also available in: Atom PDF