Bug #86227

Make xml-sitemap links absolute

Added by Wittkiel Gruppe 2 months ago. Updated about 2 months ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2018-09-11
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

As stated in https://support.google.com/webmasters/answer/183668?hl=en#general-guidelines the URLs in sitemap should be "fully-qualified URLs. Google will crawl your URLs exactly as listed. For instance, if your site is at https://www.example.com/, don't specify a URL as https://example.com/ (missing www) or ./mypage.html (a relative URL)."

Our config:
No domain in sys_domain or TypoScript.

Site-Configuration:

site:
  rootPageId: 1
  base: /
  languages:
    -
      languageId: '0'
      title: Deutsch
      navigationTitle: Deutsch
      base: /
      locale: de_DE.UTF-8
      iso-639-1: de
      hreflang: de-DE
      direction: ltr
      typo3Language: de
      flag: de
      enabled: true
  errorHandling: {  }

Non-composer
TYPO3 9.4.0
PHP 7.2

xml-sitemap-relative.png View (9.69 KB) Wittkiel Gruppe, 2018-09-11 08:45

History

#1 Updated by Wittkiel Gruppe 2 months ago

  • Subject changed from Make sitemap links absolute to Make xml-sitemap links absolute
  • Priority changed from Should have to Must have

#2 Updated by Wittkiel Gruppe 2 months ago

  • Description updated (diff)

#3 Updated by Richard Haeser 2 months ago

This issue occurs because no full domain is given in path. Have to discuss if we want to support his from core.

#4 Updated by Georg Ringer 2 months ago

  • Related to Task #86224: Make hreflang links absolute added

#5 Updated by Richard Haeser 2 months ago

  • Related to deleted (Task #86224: Make hreflang links absolute)

#6 Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58259

#7 Updated by Richard Haeser about 2 months ago

  • Target version deleted (9 LTS)

With the right setup of your site, you will already have absolute links. Only when you don't specify a domain, you won't get absolute URL's. First there should be a decision if the core "accepts" configuration without a domain.

#8 Updated by Georg Ringer about 2 months ago

  • Category changed from SEO to Link Handling, Site Handling & Routing
  • Status changed from Under Review to Rejected

I am closing this issue because of conceptional issues. If / is given, there is no chance to create an absolute url in every case like CLI. this would be then guessing and also leads to lot other troubles like caches.

So if you need absolute urls, provide a domain and all is fine

Also available in: Atom PDF