Project

General

Profile

Actions

Bug #86296

closed

Epic #90674: Backend UI not reflecting permissions

no drag and drop for restricted users if authMode is explicitDeny

Added by Attila Glück over 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2018-09-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Drag and drop is only for admins possible if use following TCA config:
$GLOBALS['TCA']['tt_content']['columns']['CType']['config']['authMode'] = 'explicitDeny';
$GLOBALS['TCA']['tt_content']['columns']['list_type']['config']['authMode'] = 'explicitDeny';

Actions #1

Updated by Attila Glück over 5 years ago

Typo3 v.8 is also affected.
With explicitAllow (on allowed content elements) works.

Actions #2

Updated by Riccardo De Contardi over 4 years ago

  • Parent task set to #90674
Actions #3

Updated by Susanne Moog about 4 years ago

  • Category set to Backend User Interface
Actions #4

Updated by Susanne Moog about 4 years ago

  • Status changed from New to Closed

If you set the settings you mentioned you then need to allow the content types for the editor, as they are only allowed to modify (and moving is a modification) content that they are allowed to edit.

Just tested this again with your settings and allowing an editor content permissions and drag and drop works fine.

Actions #5

Updated by Attila Glück 11 months ago

  • TYPO3 Version changed from 9 to 11

This ist still an issue. Maybe your config is not the right one or i miss something.

Actions

Also available in: Atom PDF