Task #86323

Simplify site configuration yaml // keep non-GUI keys

Added by Susanne Moog 12 months ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2018-09-20
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

We should avoid superfluous nesting levels in yaml configuration as it makes it harder to configure. Additionally it would be nice, if the yaml configuration for sites would be extensible - even if the GUI is not.


Related issues

Related to TYPO3 Core - Bug #86333: Make persisting new site configuration possible again Closed 2018-09-20
Related to TYPO3 Core - Bug #86437: Site Configuration backend module breaks Closed 2018-09-29

Associated revisions

Revision 9382dd61 (diff)
Added by Susanne Moog 12 months ago

[TASK] Remove superfluous indention level in site configuration yaml

The site configuration is in folder "sites" in a file called config and
does not need a "site" key to identify its purpose. To keep writing the
config as easy as possible the site configuration moved one level up and
now resides directly in config.yaml.

Additionally on writing top level keys that are not written by the GUI
will be kept, so extension authors can add additional configuration to
the site object without needing to configure the GUI (as that is hardly
extensible in the current state). Array keys // top level objects that
are configurable via GUI are however overwritten completely.

Resolves: #86323
Releases: master
Change-Id: I6100dbf53b0953e593a6156837de1fe013a74fae
Reviewed-on: https://review.typo3.org/58341
Reviewed-by: Tobi Kretschmann <>
Tested-by: Tobi Kretschmann <>
Tested-by: TYPO3com <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

Revision 2e675f21 (diff)
Added by Georg Ringer 12 months ago

[BUGFIX] Initialize site configuration for new sites

Since a regression in #86323 the site configuration for new sites
must be initialized correctly to avoid exceptions.

Resolves: #86333
Related: #86323
Releases: master
Change-Id: I4d44c01e7789f62811208e1e29655c92821e6b95
Reviewed-on: https://review.typo3.org/58352
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision d66dd1ee (diff)
Added by Benni Mack 12 months ago

[BUGFIX] Allow to edit legacy site configuration files in BE

We recently removed the "site" base prefix within the yaml
configuration file of a site configuration.

However, the indention is wrong when using FormEngine
to edit the site configuration within the "old" syntax.

Resolves: #86437
Related: #86323
Releases: master
Change-Id: I487940188b04c4977d179337cb142f2452c3bace
Reviewed-on: https://review.typo3.org/58449
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Gerrit Code Review 12 months ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58341

#2 Updated by Susanne Moog 12 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Christian Kuhn 12 months ago

  • Related to Bug #86333: Make persisting new site configuration possible again added

#4 Updated by Benni Mack 12 months ago

  • Related to Bug #86437: Site Configuration backend module breaks added

#5 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF