Bug #86399

Wrong processed folder resolved, when folder is configured to be on a different storage

Added by Helmut Hummel over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Start date:
2018-09-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

During generation of processed files, a wrong processed folder is returned.

Szenario

Given the following storage configurations:

Storage 1: processed folder "foo"
Storage 2: processed folder "1:/bar"

Observation 1

When an image of Storage 2 is processed

I expect subfolders are generated in "1:/bar"

What happens is that subfolders are generated for "1:/foo" as well as for "1:/bar".

Observation 2

When an image of Storage 2 is processed, sys_file_processedfile record does not exist, but the file exists in "1:/bar/a/b/"

I expect the file not to be regenerated

What happens is that the file is regenerated, because it is looked for in "1:/foo/a/b/" first


Related issues

Related to TYPO3 Core - Bug #66209: ProcessedFile::setName checks existence for new objectsClosed2015-04-01

Actions
#1

Updated by Helmut Hummel over 2 years ago

  • Description updated (diff)
#2

Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58410

#3

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58410

#4

Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58452

#5

Updated by Helmut Hummel over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed
#7

Updated by Susanne Moog about 2 years ago

  • Related to Bug #66209: ProcessedFile::setName checks existence for new objects added

Also available in: Atom PDF