Project

General

Profile

Actions

Bug #86553

closed

Workspaces stagin action change fatal error.

Added by Andriy Khamuliak over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2018-10-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

Function buildUriForWorkspaceSplitPreview of TYPO3\CMS\Workspaces\Preview\PreviewUriBuilder throws fatal error if called with $addDomain = true

at line

    return BackendUtility::getViewDomain($uid) . 'index.php?redirect_url=' . urlencode($viewScript);

Which says that urlencode must have string as argument and not an object.

I assume this line must be changed to

    return BackendUtility::getViewDomain($uid) . 'index.php?redirect_url=' . urlencode((string)$viewScript);

as we have at sting below in $addDomain = false case.

Workspaces staging action change are not working because of it.

After that change performed form can be submitted and mails are send, but markers

'###PREVIEW_LINK###'] and ['###SPLITTED_PREVIEW_LINK###'] are wrongly rendered with TYPO3\CMS\Workspaces\Preview\PreviewUriBuilder

it still uses old style URLs and preview link f.e. looks like:

http://example.com/index.php?&ADMCMD_prev=7fd5c4d6dc9a382aebf001dc32b781ec&id=12

Which causes 404 Page Not Found status.

if manually change url to speaking one and add generated ADMCMD argument all works fine.

Actions #1

Updated by Georg Ringer over 5 years ago

  • Category changed from Workspaces to Link Handling, Site Handling & Routing
Actions #2

Updated by Susanne Moog over 5 years ago

  • Sprint Focus set to On Location Sprint
Actions #3

Updated by Andreas Kienast about 5 years ago

  • Status changed from New to Resolved

Issue has been resolved with #86928, so I'll close this ticket now.

Actions #4

Updated by Benni Mack almost 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF