Bug #86560

Impossible to install typo3/cms-base-distribution 9.5.0 via composer

Added by Dmitry Dulepov 10 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-10-03
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

According to https://docs.typo3.org/typo3cms/InstallationGuide/QuickInstall/Composer/Index.html the official way to install 9.5.0 is:

# Download the Base Distribution, the latest "stable" release (9.5)
composer create-project typo3/cms-base-distribution YourNewProjectFolder```

However it install 9.4.0 because 9.5.0 tag is missing from https://packagist.org/packages/typo3/cms-base-distribution

The output of the above command is:

MBP3:~/tmp $ composer create-project typo3/cms-base-distribution YourNewProjectFolder
Installing typo3/cms-base-distribution (v9.4.0)
  - Installing typo3/cms-base-distribution (v9.4.0): Downloading (100%)
Created project in YourNewProjectFolder
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 73 installs, 0 updates, 0 removals
  - Installing typo3/cms-composer-installers (v2.2.0): Downloading (100%)
  - Installing typo3/class-alias-loader (1.0.1): Downloading (100%)
  - Installing helhum/typo3-console-plugin (2.0.4): Downloading (100%)
  - Installing helhum/config-loader (v0.9.0): Downloading (100%)
  - Installing symfony/process (v4.1.6): Downloading (100%)
  - Installing symfony/polyfill-mbstring (v1.9.0): Loading from cache
  - Installing symfony/console (v4.1.6): Loading from cache
  - Installing psr/log (1.0.2): Loading from cache
  - Installing doctrine/lexer (v1.0.1): Loading from cache
  - Installing doctrine/annotations (v1.6.0): Loading from cache
  - Installing typo3fluid/fluid (2.5.4): Loading from cache
  - Installing typo3/phar-stream-wrapper (v3.0.0): Loading from cache
  - Installing typo3/cms-cli (2.0.0): Loading from cache
  - Installing symfony/polyfill-intl-icu (v1.9.0): Loading from cache
  - Installing symfony/intl (v4.1.6): Loading from cache
  - Installing doctrine/inflector (v1.3.0): Loading from cache
  - Installing doctrine/collections (v1.5.0): Loading from cache
  - Installing doctrine/cache (v1.8.0): Loading from cache
  - Installing guzzlehttp/promises (v1.3.1): Loading from cache
  - Installing psr/http-message (1.0.1): Loading from cache
  - Installing guzzlehttp/psr7 (1.4.2): Loading from cache
  - Installing guzzlehttp/guzzle (6.3.3): Loading from cache
  - Installing mso/idna-convert (v1.1.0): Loading from cache
  - Installing cogpowered/finediff (0.3.1): Loading from cache
  - Installing typo3/cms-core (v9.5.0): Downloading (100%)
  - Installing symfony/polyfill-ctype (v1.9.0): Loading from cache
  - Installing symfony/yaml (v4.1.6): Loading from cache
  - Installing symfony/finder (v4.1.6): Loading from cache
  - Installing swiftmailer/swiftmailer (v5.4.12): Loading from cache
  - Installing typo3/cms-recordlist (v9.5.0): Downloading (100%)
  - Installing typo3/cms-extbase (v9.5.0): Downloading (100%)
  - Installing typo3/cms-fluid (v9.5.0): Downloading (100%)
  - Installing nikic/php-parser (v4.0.4): Loading from cache
  - Installing typo3/cms-install (v9.5.0): Downloading (100%)
  - Installing typo3/cms-frontend (v9.5.0): Downloading (100%)
  - Installing typo3/cms-filelist (v9.5.0): Downloading (100%)
  - Installing typo3/cms-extensionmanager (v9.5.0): Downloading (100%)
  - Installing typo3/cms-backend (v9.5.0): Downloading (100%)
  - Installing doctrine/instantiator (1.0.5): Loading from cache
  - Installing psr/http-server-handler (1.0.0): Loading from cache
  - Installing psr/http-server-middleware (1.0.0): Loading from cache
  - Installing psr/container (1.0.0): Loading from cache
  - Installing doctrine/event-manager (v1.0.0): Loading from cache
  - Installing doctrine/reflection (v1.0.0): Loading from cache
  - Installing doctrine/persistence (v1.0.1): Loading from cache
  - Installing doctrine/common (v2.9.0): Loading from cache
  - Installing doctrine/dbal (v2.7.2): Loading from cache
  - Installing symfony/routing (v4.1.6): Loading from cache
  - Installing psr/simple-cache (1.0.1): Loading from cache
  - Installing psr/cache (1.0.1): Loading from cache
  - Installing symfony/cache (v4.1.6): Loading from cache
  - Installing symfony/expression-language (v4.1.6): Loading from cache
  - Installing typo3/cms-scheduler (v9.5.0): Downloading (100%)
  - Installing helhum/typo3-console (5.5.5): Downloading (100%)
  - Installing typo3/cms-seo (v9.5.0): Downloading (100%)
  - Installing typo3/cms-fluid-styled-content (v9.5.0): Downloading (100%)
  - Installing typo3/cms-adminpanel (v9.5.0): Downloading (100%)
  - Installing typo3/cms-viewpage (v9.5.0): Downloading (100%)
  - Installing typo3/cms-tstemplate (v9.5.0): Downloading (100%)
  - Installing typo3/cms-t3editor (v9.5.0): Downloading (100%)
  - Installing typo3/cms-sys-note (v9.5.0): Downloading (100%)
  - Installing typo3/cms-setup (v9.5.0): Downloading (100%)
  - Installing typo3/cms-rte-ckeditor (v9.5.0): Downloading (100%)
  - Installing typo3/cms-reports (v9.5.0): Downloading (100%)
  - Installing typo3/cms-redirects (v9.5.0): Downloading (100%)
  - Installing typo3/cms-info (v9.5.0): Downloading (100%)
  - Installing typo3/cms-impexp (v9.5.0): Downloading (100%)
  - Installing typo3/cms-form (v9.5.0): Downloading (100%)
  - Installing typo3/cms-felogin (v9.5.0): Downloading (100%)
  - Installing typo3/cms-beuser (v9.5.0): Downloading (100%)
  - Installing typo3/cms-belog (v9.5.0): Downloading (100%)
  - Installing typo3/cms-about (v9.5.0): Downloading (100%)
helhum/config-loader suggests installing ext-yaml (For improved performance when parsing yaml files you should use the PECL YAML Parser php extension)
symfony/console suggests installing psr/log-implementation (For using the console logger)
symfony/console suggests installing symfony/event-dispatcher ()
symfony/console suggests installing symfony/lock ()
symfony/polyfill-intl-icu suggests installing ext-intl (For best performance)
symfony/intl suggests installing ext-intl (to use the component with locales other than "en")
doctrine/cache suggests installing alcaeus/mongo-php-adapter (Required to use legacy MongoDB driver)
typo3/cms-core suggests installing ext-gd (GDlib/Freetype is required for building images with text (GIFBUILDER) and can also be used to scale images)
typo3/cms-core suggests installing ext-intl (TYPO3 with unicode-based filesystems)
typo3/cms-core suggests installing ext-mysqli ()
typo3/cms-core suggests installing ext-zip ()
symfony/routing suggests installing symfony/config (For using the all-in-one router or any loader)
symfony/routing suggests installing symfony/dependency-injection (For loading routes from a service)
symfony/routing suggests installing symfony/http-foundation (For using a Symfony Request object)
Writing lock file
Generating autoload files
Generating class alias map file
Inserting class alias loader into main autoload.php file
> typo3cms install:fixfolderstructure
The following directory structure has been fixed:
Directory /typo3temp successfully created.
Fixed permission on /typo3temp.
File /typo3temp/index.html successfully created.
Set content to /typo3temp/index.html
Fixed permission on /typo3temp/index.html.
Directory /typo3temp/assets successfully created.
Fixed permission on /typo3temp/assets.
Directory /typo3temp/assets/compressed successfully created.
Fixed permission on /typo3temp/assets/compressed.
Directory /typo3temp/assets/css successfully created.
Fixed permission on /typo3temp/assets/css.
Directory /typo3temp/assets/js successfully created.
Fixed permission on /typo3temp/assets/js.
Directory /typo3temp/assets/images successfully created.
Fixed permission on /typo3temp/assets/images.
Directory /typo3temp/assets/_processed_ successfully created.
Fixed permission on /typo3temp/assets/_processed_.
Directory /typo3temp/var successfully created.
Fixed permission on /typo3temp/var.
File /typo3temp/var/.htaccess successfully created.
Set content to /typo3temp/var/.htaccess
Fixed permission on /typo3temp/var/.htaccess.
Directory /typo3temp/var/charset successfully created.
Fixed permission on /typo3temp/var/charset.
Directory /typo3temp/var/cache successfully created.
Fixed permission on /typo3temp/var/cache.
Directory /typo3temp/var/lock successfully created.
Fixed permission on /typo3temp/var/lock.
Directory /typo3conf successfully created.
Fixed permission on /typo3conf.
Directory /typo3conf/ext successfully created.
Fixed permission on /typo3conf/ext.
Directory /typo3conf/l10n successfully created.
Fixed permission on /typo3conf/l10n.
Directory /fileadmin successfully created.
Fixed permission on /fileadmin.
Directory /fileadmin/_temp_ successfully created.
Fixed permission on /fileadmin/_temp_.
File /fileadmin/_temp_/.htaccess successfully created.
Set content to /fileadmin/_temp_/.htaccess
Fixed permission on /fileadmin/_temp_/.htaccess.
File /fileadmin/_temp_/index.html successfully created.
Set content to /fileadmin/_temp_/index.html
Fixed permission on /fileadmin/_temp_/index.html.
Directory /fileadmin/user_upload successfully created.
Fixed permission on /fileadmin/user_upload.
Directory /fileadmin/user_upload/_temp_ successfully created.
Fixed permission on /fileadmin/user_upload/_temp_.
File /fileadmin/user_upload/_temp_/index.html successfully created.
Set content to /fileadmin/user_upload/_temp_/index.html
Fixed permission on /fileadmin/user_upload/_temp_/index.html.
Directory /fileadmin/user_upload/_temp_/importexport successfully created.
Fixed permission on /fileadmin/user_upload/_temp_/importexport.
File /fileadmin/user_upload/_temp_/importexport/.htaccess successfully created.
Set content to /fileadmin/user_upload/_temp_/importexport/.htaccess
Fixed permission on /fileadmin/user_upload/_temp_/importexport/.htaccess.
File /fileadmin/user_upload/_temp_/importexport/index.html successfully created.
Set content to /fileadmin/user_upload/_temp_/importexport/index.html
Fixed permission on /fileadmin/user_upload/_temp_/importexport/index.html.
File /fileadmin/user_upload/index.html successfully created.
Set content to /fileadmin/user_upload/index.html
Fixed permission on /fileadmin/user_upload/index.html.
> typo3cms install:generatepackagestates
The following extensions have been added to the generated PackageStates.php file: core, scheduler, extbase, fluid, frontend, fluid_styled_content, install, reports, setup, rte_ckeditor, about, adminpanel, backend, belog, beuser, extensionmanager, felogin, filelist, form, impexp, info, recordlist, redirects, seo, sys_note, t3editor, tstemplate, viewpage

Interestingly some extension are from v9.5.0. Not sure if it was intended to install 9.5.0 extensions with 9.4.0.

done.png View (61.2 KB) Josef Glatz, 2018-10-03 18:38

History

#1 Updated by Andreas Wolf 10 months ago

I agree that this is confusing, but version 9.4.0 of the distribution actually includes all dependencies with ^9.4 as the version constraint, which translates to >=9.4.0 <10. So this will always use the latest 9.5.x now (as there won't be a 9.6.x).

#2 Updated by Josef Glatz 10 months ago

  • File done.png View added
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Fixed

as mentioned: https://typo3.slack.com/archives/C028J3N83/p1538583287000100?thread_ts=1538582100.000100&cid=C028J3N83

Seems like this is something which is not included in the default release process. IMO this should be part of it somehow.

Running composer create-project typo3/cms-base-distribution foo shows 9.5.0 now:

#3 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF