Bug #86851

Core relates to SqlExpectedSchemaService which has been dropped

Added by Stefan Froemken 8 months ago. Updated 4 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2018-11-05
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello Core-Team,

I just found following lines in Core:

$signalSlotDispatcher->connect(
    'TYPO3\\CMS\\Install\\Service\\SqlExpectedSchemaService',
    'tablesDefinitionIsBeingBuilt',
    \TYPO3\CMS\Core\Category\CategoryRegistry::class,
    'addCategoryDatabaseSchemaToTablesDefinition'
);

But as of breaking change 82148:
https://docs.typo3.org/typo3cms/extensions/core/Changelog/9.0/Breaking-82148-DownloadSQLDumpDroppedInEM.html

you have removed SqlExpectedSchemaService. So, the lines from above can't work, right?

Stefan

History

#1 Updated by Sybille Peters 8 months ago

The above code still works (signal gets emitted and caught), but it is weird.

Additionally, the Changelog contradicts itself:

#2 Updated by Sybille Peters 8 months ago

Also, it looks like the functionality (use signal to make dynamic database changes) has been dropped without any replacement ...?

#3 Updated by Florian Wessels 4 months ago

Hi,

functionality is still there as

TYPO3\CMS\Core\Database\Schema\SqlReader::emitTablesDefinitionIsBeingBuiltSignal
is still using the signal class name
'TYPO3\\CMS\\Install\\Service\\SqlExpectedSchemaService'
.
This is very confusing.
Maybe the signal slot should better use its real SqlReader class name ;-)

#4 Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59874

#5 Updated by Mathias Brodala 4 months ago

  • Status changed from Under Review to Rejected

The current code works as intended to keep backwards compatibility.

Also available in: Atom PDF