Bug #86910

All text input fields get required="required" attribute

Added by Alexander Grein 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Must have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2018-11-12
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

To reproduce, 1. generate a test.form.yml using a simple text Node:

identifier: test
label: 'Test'
prototypeName: standard
type: Form
renderables:
  -
    identifier: page-1
    type: Page
    label: 'Page 1'
    renderables:
      -
        identifier: test
        type: Text
        label: Test
        properties:
          fluidAdditionalAttributes:
            placeholder: Test

2. Choose this form in a form content element
3. Open page with the generated form in the frontend

Expected: A form containing a input field without a required="required" attribute

Reality: A form with a required="required" attribute


Related issues

Duplicates TYPO3 Core - Bug #86890: AbstractTagBasedViewHelper recycles the TagBuilder Resolved 2018-11-08

Associated revisions

Revision 3469afec (diff)
Added by Gerrit Mohrmann 3 months ago

[TASK] Update typo3fluid/fluid to 2.6.0

Fixes missing output in ifAuthenticatedViewHelper after cache clearing
and erroneous replication of field properties to subsequent fields.

composer command used:
composer update typo3fluid/fluid

Resolves: #86930
Resolves: #86890
Resolves: #87430
Resolves: #86910
Resolves: #87586
Releases: master, 9.5
Change-Id: I8d1abd0aa08d7d7399ec23675dcf07d08dbdd2f2
Reviewed-on: https://review.typo3.org/59554
Tested-by: TYPO3com <>
Reviewed-by: Jonas Eberle <>
Tested-by: Jonas Eberle <>
Reviewed-by: Oliver Klee <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Mona Muzaffar <>
Tested-by: Mona Muzaffar <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

Revision 3ee1346a (diff)
Added by Gerrit Mohrmann 3 months ago

[TASK] Update typo3fluid/fluid to 2.6.0

Fixes missing output in ifAuthenticatedViewHelper after cache clearing
and erroneous replication of field properties to subsequent fields.

composer command used:
composer update typo3fluid/fluid

Resolves: #86930
Resolves: #86890
Resolves: #87430
Resolves: #86910
Resolves: #87586
Releases: master, 9.5
Change-Id: I8d1abd0aa08d7d7399ec23675dcf07d08dbdd2f2
Reviewed-on: https://review.typo3.org/59609
Tested-by: TYPO3com <>
Reviewed-by: Mona Muzaffar <>
Tested-by: Mona Muzaffar <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Alexander Grein 5 months ago

Additional Info about this bug:

It only happens right after clearing caches and reload the form page the first time.

After reloading the same page again, the additional required attribute disappears.

#2 Updated by Wouter Wolters 5 months ago

  • Duplicates Bug #86890: AbstractTagBasedViewHelper recycles the TagBuilder added

#3 Updated by Wouter Wolters 5 months ago

  • Status changed from New to Closed

Duplicates #86890 please continue there

#4 Updated by Jonas Eberle 5 months ago

Just to add this here:

I cannot reproduce with just 1 (unrequired) field. To reproduce, I have to add 1 required field before.
Do you only have 1 form on this page?

#5 Updated by Alexander Grein 5 months ago

No, I have several required fields before.
I did not think that mattered.

#6 Updated by Gerrit Code Review 3 months ago

  • Status changed from Closed to Under Review

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59554

#7 Updated by Gerrit Code Review 3 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59554

#8 Updated by Gerrit Code Review 3 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59554

#9 Updated by Gerrit Code Review 3 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59609

#10 Updated by Gerrit Mohrmann 3 months ago

  • Status changed from Under Review to Resolved

Also available in: Atom PDF