Bug #87045

different pagetree in Backend and Link-wizard

Added by Dieter Porth 8 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-11-29
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Local system
- Windows / xampp / php 7.0

The Pagetree in the Link-module of the Linkfield oder in the ckeditor ia different to the shown page-tree.

The Screenshots are taken with firefox unsing its developer-tools.
The place of the first accordion-triangle in the pagetree seems to be used by two different DOM-elements. The hover-effekt for Dom-element in developer-tools of firefox tfor two diffrent DOM-Elements indicates the same region.

The effect holds on after clearing the typo3temp-folder and truncating all cf*-tables.

The Link of the Pop-up-Windows for the Link-Wizard is:

http://dueddelei.local/typo3/index.php?route=%2Fwizard%2Flink%2Fbrowse&token=929dfef2fc2fc9891cee8d159e295aad5da56a11&P%5Btable%5D=tt_content&P%5Buid%5D=NEW5c005fbb6c5c0300759676&P%5Bpid%5D=-118&P%5Bfield%5D=header_link&P%5BformName%5D=editform&P%5BitemName%5D=data%5Btt_content%5D%5BNEW5c005fbb6c5c0300759676%5D%5Bheader_link%5D&P%5Bhmac%5D=102199fc489b80e5027950855117ae91d193de54&P%5BfieldChangeFunc%5D%5BTBE_EDITOR_fieldChanged%5D=TBE_EDITOR.fieldChanged%28%27tt_content%27%2C%27NEW5c005fbb6c5c0300759676%27%2C%27header_link%27%2C%27data%5Btt_content%5D%5BNEW5c005fbb6c5c0300759676%5D%5Bheader_link%5D%27%29%3B&P%5BfieldChangeFuncHash%5D=0e24da437510d4369eee40b821970e423e248e02&P[currentValue]=&P[currentSelectedValues]=

2018-11-29 22_59_00-Window.png View - Popup for link-wizrad with firefox-developer-tools - 1. hover (72.9 KB) Dieter Porth, 2018-11-29 23:11

2018-11-29 22_59_17-Window.png View - Popup for link-wizrad with firefox-developer-tools - 2. hover (74.3 KB) Dieter Porth, 2018-11-29 23:11

2018-11-29 23_21_17-Window.png View - example - linkbox of ckeditor (overlay - 1. Position of mouse) (165 KB) Dieter Porth, 2018-11-29 23:23

2018-11-29 23_21_26-Window.png View - example 2 - linkbox of ckeditor (overlay - 2. position of mouse) (162 KB) Dieter Porth, 2018-11-29 23:23

2018-11-29 23_06_43-Window.png View - different pagetrees - missing triangle (108 KB) Dieter Porth, 2018-11-29 23:36


Related issues

Related to TYPO3 Core - Bug #86790: Linkbrowser layout issues in Firefox 63.0 (64-Bit) Closed 2018-10-29
Related to TYPO3 Core - Bug #87280: Trees have different markup Closed 2018-12-23

History

#1 Updated by Dieter Porth 8 months ago

xdebug-analysis
The value of $this->BE_USER->uc['browseTrees']['browsePages'] is wrong.

#2 Updated by Michael Stopp 6 months ago

It seems that the missing triangle on the first page tree node has to do with the fact that the title of the page overflows the width of the page tree pane. If you have page titles of varying length, you can individually make them appear/disappear by horizontally resizing the popup. My guess is that this is a CSS problem.

We observed this in Firefox on Windows and Mac. Safari and Chrome were ok in both cases.

#3 Updated by Riccardo De Contardi 6 months ago

  • Status changed from New to Needs Feedback

Should be solved after the merging of the patch from #86790 could you test? (See also #87280)

#4 Updated by Riccardo De Contardi 3 months ago

  • Related to Bug #86790: Linkbrowser layout issues in Firefox 63.0 (64-Bit) added

#5 Updated by Riccardo De Contardi 3 months ago

  • Related to Bug #87280: Trees have different markup added

#6 Updated by Riccardo De Contardi 3 months ago

  • Status changed from Needs Feedback to Closed

I am confident that this issue has been solved with the issues I mentioned on my previous comments; therefore I'm closing it for now. Moreover, there has been no feedback since the last 90 days.

Of course, if you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or ping me.

Thank you and best regards.

Also available in: Atom PDF