Bug #87116

Pagetitle is never loaded from cache

Added by Markus Opahle almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
SEO
Target version:
-
Start date:
2018-12-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In \TYPO3\CMS\Core\PageTitle\PageTitleProviderManager::getTitle() $this->pageCache is tested to be an instance of \TYPO3\CMS\Core\Cache\Backend\AbstractBackend, which could never be true since it is a CacheFrontend not a Backend.

Thus, all Pagetitle providers will be called even on cached pages.

Testet in TYPO3 9.5.1

#1

Updated by Josef Glatz almost 3 years ago

  • Category set to SEO
#2

Updated by Richard Haeser almost 3 years ago

  • Status changed from New to Accepted
#3

Updated by Gerrit Code Review almost 3 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59082

#4

Updated by Richard Haeser almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF