Bug #87186

Missing namespace for TypoScriptFrontendController in CObjectViewHelper

Added by David Bruchmann 8 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Fluid
Target version:
Start date:
2018-12-17
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

In the CObjectViewHelper is this function:

    /**
     * @return ContentObjectRenderer
     */
    protected static function getContentObjectRenderer()
    {
        return GeneralUtility::makeInstance(
            ContentObjectRenderer::class,
            $GLOBALS['TSFE'] ?? GeneralUtility::makeInstance(TypoScriptFrontendController::class, null, 0, 0)
        );
    }

Here TypoScriptFrontendController has no namespace and that throws an error.

Adding "use TYPO3\CMS\Frontend\Controller\TypoScriptFrontendController;" above the class solves the issue;

Version: 9.5.3;


Related issues

Related to TYPO3 Core - Bug #86979: stdWrap fieldRequired/insertData sometimes not working as expected since TYPO3 9 LTS Closed 2018-11-22

Associated revisions

Revision e6dc7153 (diff)
Added by Georg Ringer 8 months ago

[BUGFIX] Add missing use statement in CObjectViewHelper

The use statement for TypoScriptFrontendController is added.

Resolves: #87186
Releases: master, 9.5
Change-Id: I2b758b3ac9bcd4002844160614ee1a9c7bc72585
Reviewed-on: https://review.typo3.org/59185
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Tested-by: TYPO3com <>
Reviewed-by: Josef Glatz <>
Tested-by: Josef Glatz <>
Reviewed-by: Richard Haeser <>
Tested-by: Richard Haeser <>
Reviewed-by: Guido Schmechel <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

Revision aa4358b2 (diff)
Added by Georg Ringer 8 months ago

[BUGFIX] Add missing use statement in CObjectViewHelper

The use statement for TypoScriptFrontendController is added.

Resolves: #87186
Releases: master, 9.5
Change-Id: I2b758b3ac9bcd4002844160614ee1a9c7bc72585
Reviewed-on: https://review.typo3.org/59187
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59185

#2 Updated by Markus Klein 8 months ago

  • Related to Bug #86979: stdWrap fieldRequired/insertData sometimes not working as expected since TYPO3 9 LTS added

#3 Updated by Gerrit Code Review 8 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59185

#4 Updated by Georg Ringer 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Gerrit Code Review 8 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59187

#6 Updated by Georg Ringer 8 months ago

  • Status changed from Under Review to Resolved

#7 Updated by Benni Mack 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF