Bug #87256

Pages with nav_hide=1 become "Page enabled in menus" as tooltip

Added by Andreas Krämer 9 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Pagetree
Start date:
2018-12-21
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

But of course it should be "Page not enabled in menus" or "Hide in Menu" like before.

I guess this came with the invertStateDisplay of the nav_hide field and therefore the "inverted" naming.

page-enabled.png View (2.18 KB) Andreas Krämer, 2018-12-21 10:05

Associated revisions

Revision 5cdc68f4 (diff)
Added by Guido Schmechel 8 months ago

[BUGFIX] Corrected tooltip for pages with nav_hide

The inverted state of the nav_hide values is now considered.
For this purpose, the original label is supplemented again.

Resolves: #87256
Releases: master, 9.5
Change-Id: I8893a15744464af33d2147f1df42b25344d7de92
Reviewed-on: https://review.typo3.org/59270
Tested-by: Riccardo De Contardi <>
Tested-by: TYPO3com <>
Reviewed-by: Stefanos Karasavvidis <>
Tested-by: Stefanos Karasavvidis <>
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>

Revision 5b9630db (diff)
Added by Guido Schmechel 7 months ago

[BUGFIX] Corrected tooltip for pages with nav_hide

The inverted state of the nav_hide values is now considered.
For this purpose, the original label is supplemented again.

Resolves: #87256
Releases: master, 9.5
Change-Id: I8893a15744464af33d2147f1df42b25344d7de92
Reviewed-on: https://review.typo3.org/59656
Reviewed-by: Josef Glatz <>
Tested-by: Josef Glatz <>
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59270

#2 Updated by Gerrit Code Review 8 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59270

#3 Updated by Guido Schmechel 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Gerrit Code Review 7 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59656

#5 Updated by Gerrit Code Review 7 months ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59656

#6 Updated by Josef Glatz 7 months ago

Fix was not backported and only available in master.

#7 Updated by Gerrit Code Review 7 months ago

Patch set 3 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59656

#8 Updated by Guido Schmechel 7 months ago

  • Status changed from Under Review to Resolved

#9 Updated by Benni Mack 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF