Bug #87348

Task group is lost when task is executed

Added by Christian Toffolo about 2 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
scheduler
Target version:
-
Start date:
2019-01-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

"Task group" is a data serialized in serialized_task_object (`taskGroup`) but it's also duplicated as field `task_group` in table `tx_scheduler_task`.
(like other data in this table)

In this case the task group is lost on execution of the task itself.

Better not duplicate data saving it both as field and as serialized inside a blob field.

#1

Updated by Benni Mack almost 2 years ago

  • Status changed from New to Needs Feedback

Hey Christian,

does this happen on every task or a custom task by a third-party extension?

Thanks for your feedback.
Benni.

#2

Updated by Christian Toffolo almost 2 years ago

Hello Benni,
it happens in every task.

#3

Updated by Benni Mack over 1 year ago

  • Target version changed from next-patchlevel to Candidate for patchlevel
#4

Updated by Susanne Moog 11 months ago

I cannot reproduce this issue, do you have any special task configuration / database or anything else that might influence this?

#5

Updated by Riccardo De Contardi 7 months ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

#6

Updated by Riccardo De Contardi 7 months ago

  • Target version deleted (Candidate for patchlevel)

Also available in: Atom PDF