Bug #87426

label_alt + label_alt_force for IRRE childs cannot be overwritten using OverrideChildTca()

Added by Jan Kornblum 7 months ago. Updated 23 days ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2019-01-14
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I tried to overwrite childs (IRRE) appearance (label_alt, label_alt_force) for performance reasons in BE (https://forge.typo3.org/issues/82730):

'columns' => [
    'childs' => [
        'config' => [
            'type' => 'inline',
            'foreign_table' => 'tx_ext_domain_model_child',
            'foreign_field' => 'parent',
            'overrideChildTca' => [
                'ctrl' => [
                    'label_alt' => '',
                    'label_alt_force' => false,
                ]
            ],    
        ],
    ],
]

History

#1 Updated by Georg Ringer 7 months ago

overrideChildTca can currently only be used for overriding types and columns but not the ctrl section, see \TYPO3\CMS\Backend\Form\FormDataProvider\InlineOverrideChildTca. This is not really easy to solve as code like BackendUtility and others rely on checking the TCA directly without passing required information like the parent table.

don't expect that to be changed, even more I tend to close this issue - it is certainly a feature and not a bug.

#2 Updated by Georg Ringer 7 months ago

  • Status changed from New to Needs Feedback
  • Priority changed from Must have to Could have

#3 Updated by Jan Kornblum 7 months ago

OK, thanks for the explanation... Close it or let it be a possible missing feature ;)

#4 Updated by Riccardo De Contardi 23 days ago

  • Status changed from Needs Feedback to Closed

Thank you for your reply and sorry for this late update; I close this one for now. Feel free to reopen it or ping me if in need.

Best regards.

Also available in: Atom PDF