Bug #87500

Site Configuration with an empty static route is possible

Added by Guido Schmechel over 1 year ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2019-01-20
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Error

The problem occurs when opening the sitemap.

(1/1) TypeError
Argument 1 passed to TYPO3\CMS\Core\LinkHandling\LinkService::resolve() must be of the type string, null given, called in \public\typo3\sysext\frontend\Classes\Middleware\StaticRouteResolver.php on line 133

Steps to reproduce

  • Add an Static Route in Site Configuration
  • Change "Route Type" to "Page, File"
  • Backend is reloaded
  • Click "Close" to abort the adding of a route

As it stands, the mandatory field check is not performed by clicking on "Close".

Associated revisions

Revision 711a8e5e (diff)
Added by Georg Ringer 2 months ago

[BUGFIX] Skip empty static routes

Due to incomplete editing in the site module or wrong yaml configuration
it is possible that an empty static route is defined which will break
the complete frontend.

Skip empty routes as those don't make any sense.

Resolves: #87500
Releases: master, 9.5
Change-Id: I9f5737bf077fd3b2f0c38522ee3ae641c7e5cd21
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63610
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Tested-by: Daniel Goerz <>
Tested-by: Susanne Moog <>
Reviewed-by: Benni Mack <>
Reviewed-by: Daniel Goerz <>
Reviewed-by: Susanne Moog <>

Revision 9548679c (diff)
Added by Georg Ringer 2 months ago

[BUGFIX] Skip empty static routes

Due to incomplete editing in the site module or wrong yaml configuration
it is possible that an empty static route is defined which will break
the complete frontend.

Skip empty routes as those don't make any sense.

Resolves: #87500
Releases: master, 9.5
Change-Id: I9f5737bf077fd3b2f0c38522ee3ae641c7e5cd21
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63863
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Reviewed-by: Susanne Moog <>

History

#1 Updated by Guido Schmechel over 1 year ago

  • Description updated (diff)

#2 Updated by Josef Glatz over 1 year ago

That affects the entire FormEngine and not only the Site Configuration.

#3 Updated by Riccardo De Contardi over 1 year ago

  • Category set to FormEngine aka TCEforms

#4 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63610

#5 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63610

#6 Updated by Gerrit Code Review 3 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63610

#7 Updated by Gerrit Code Review 2 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63610

#8 Updated by Gerrit Code Review 2 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63610

#9 Updated by Gerrit Code Review 2 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63610

#10 Updated by Gerrit Code Review 2 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63610

#11 Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63863

#12 Updated by Georg Ringer 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#13 Updated by Benni Mack about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF