Project

General

Profile

Actions

Bug #87513

closed

indexed_search error-message if I output an empty variable

Added by Anton Mayer about 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2019-01-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,

I use Typo3 9.5.3 and the core-extension indexed_search

If I use this typoscript, I get a error-massage in the Frontend if I open Page-ID 32
"Oops, an error occurred! No Content Object definition found at TypoScript object path "lib.search" "

@plugin.tx_indexedsearch.settings {
targetPid = 32
rootPidList = {$rootId}
}

plugin.tx_indexedsearch.settings.results.markupSW_summaryMax = 120

lib.search = RECORDS
lib.search {
tables = tt_content
source = 51
dontCheckPid = 1
}

[globalVar = TSFE:id=32]
lib.search >
[global]@

The Extension is working without an error if I delete:
[globalVar = TSFE:id=32]
lib.search >
[global]

The Typosript is working with Typo3 8LTS

Actions #1

Updated by Erik Sokoll about 5 years ago

Hi Anton,

just a quick fix.
In TYPO3 Version 9 you cannot remove typoscriptObjectPath content by ">" like in "lib.search >" although this is standard practice for integrators since years.

Try to overwrite it with something empty:

lib.search >
lib.search = TEXT
lib.search.value =

Actions #2

Updated by Stefan Froemken about 5 years ago

This issue was implemented through this patch: https://review.typo3.org/#/c/58686/
5 Core Developers have made that CodeReview. Would be interesting if that will be changed again...

Actions #3

Updated by Anton Mayer about 5 years ago

  • % Done changed from 0 to 100

Thank you for your prompt reply. The solution works very well

Actions #4

Updated by Riccardo De Contardi over 2 years ago

  • Status changed from New to Closed
  • Assignee deleted (Anton Mayer)

Sorry for this very late reply; I close this issue as everything works as expected.

If you think that this is the wrong decision or I have misunderstood or that there is still something that should be done here, please reopen it or open a new issue with a reference to this one.

Thank you.

Actions

Also available in: Atom PDF