Bug #87586

ext:form field properties get inherited to subsequent fields

Added by Andreas Krämer about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2019-01-30
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

On a TYPO3 9.5.4 installation we observed the behaviour that on multiple forms the property "elementClassAttribute" of a field got inherited to all following fields of the same type (Text).

On a (mostly) blank 9.5.4 installation I could reproduce this behaviour with the attached example, but this time only the "fluidAdditionalAttributes" placeholder & autocomplete got inherited and not the "elementClassAttribute".

What's important, this only happens on the first page load after cache clearing.

Can anyone reproduce this? Steps:
  • Copy example file into form_definitions folder
  • Add form plugin to some page and choose the "Inherit test" example
  • Clear cache with "Flush all caches"
  • Open page with the form in the frontend
  • Some properties should become inherited from textfield "website" to "name"
  • After a reload of the page it works as expected

inherittest.form.yaml View - form inheritance example (1.01 KB) Andreas Krämer, 2019-01-30 15:20


Related issues

Related to TYPO3 Core - Bug #86890: AbstractTagBasedViewHelper recycles the TagBuilder Resolved 2018-11-08

Associated revisions

Revision 3469afec (diff)
Added by Gerrit Mohrmann about 2 months ago

[TASK] Update typo3fluid/fluid to 2.6.0

Fixes missing output in ifAuthenticatedViewHelper after cache clearing
and erroneous replication of field properties to subsequent fields.

composer command used:
composer update typo3fluid/fluid

Resolves: #86930
Resolves: #86890
Resolves: #87430
Resolves: #86910
Resolves: #87586
Releases: master, 9.5
Change-Id: I8d1abd0aa08d7d7399ec23675dcf07d08dbdd2f2
Reviewed-on: https://review.typo3.org/59554
Tested-by: TYPO3com <>
Reviewed-by: Jonas Eberle <>
Tested-by: Jonas Eberle <>
Reviewed-by: Oliver Klee <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Mona Muzaffar <>
Tested-by: Mona Muzaffar <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

Revision 3ee1346a (diff)
Added by Gerrit Mohrmann about 2 months ago

[TASK] Update typo3fluid/fluid to 2.6.0

Fixes missing output in ifAuthenticatedViewHelper after cache clearing
and erroneous replication of field properties to subsequent fields.

composer command used:
composer update typo3fluid/fluid

Resolves: #86930
Resolves: #86890
Resolves: #87430
Resolves: #86910
Resolves: #87586
Releases: master, 9.5
Change-Id: I8d1abd0aa08d7d7399ec23675dcf07d08dbdd2f2
Reviewed-on: https://review.typo3.org/59609
Tested-by: TYPO3com <>
Reviewed-by: Mona Muzaffar <>
Tested-by: Mona Muzaffar <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Ralf Zimmermann about 2 months ago

  • Related to Bug #86890: AbstractTagBasedViewHelper recycles the TagBuilder added

#2 Updated by Ralf Zimmermann about 2 months ago

  • Assignee set to Andreas Krämer

Is sounds like #86890.
This should be fixed with typo3fluid/fluid 2.6.0.
Can you tell me your typo3fluid/fluid Version?
I cannot reproduce your issue with TYPO3 9.5.5-dev

#3 Updated by Andreas Krämer about 2 months ago

Thanks for your feedback! Yes - sounds like duplicate of #86890.
Sorry I did not see it already has been reported.
You can close this as duplicate, thanks!

#4 Updated by Ralf Zimmermann about 2 months ago

  • Status changed from New to Closed
  • Assignee deleted (Andreas Krämer)

#5 Updated by Gerrit Code Review about 2 months ago

  • Status changed from Closed to Under Review

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59554

#6 Updated by Gerrit Code Review about 2 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59554

#7 Updated by Gerrit Code Review about 2 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59554

#8 Updated by Gerrit Code Review about 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59609

#9 Updated by Gerrit Mohrmann about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF