Bug #87710

DB check module: Building a database query where sys_language_uid=-1 not possible

Added by Josef Glatz almost 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2019-02-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem/Description

If you use the DB check > Full search > Advanced Query module in the TYPO3 backend it's actually not possible to build a SELECT query on a table where the WHERE clause has to be equal -1.

The resulting SQL query is

SELECT `uid`, `type`, `sys_language_uid`, `pid`, `deleted`
FROM `tx_theme_feature_teaser`
WHERE (tx_theme_feature_teaser.sys_language_uid = '1550085900') AND (`tx_theme_feature_teaser`.`deleted` = 0) LIMIT 100

This is the sent form data:

SET[search]: query
SET[search_query_makeQuery]: all
storeControl[STORE]: 0
storeControl[title]: 
SET[queryTable]: tx_theme_feature_teaser
SET[queryFields]: uid,type,sys_language_uid
queryConfig[0][operator]: 
queryConfig[0][type]: FIELD_sys_language_uid
queryConfig[0][comparison]: 6
queryConfig[0][inputValue]: -1
just_update: 
SET[queryGroup]: 
SET[queryOrder]: 
SET[queryLimit]: 100

The expectation is

the where clause must query sys_language_uid = -1


Files

cattura1.png (59.4 KB) cattura1.png Riccardo De Contardi, 2020-04-24 17:45

Related issues

Related to TYPO3 Core - Bug #84588: Int values for field will be converted to unix timestamp in module "DB check" -> Full searchClosedManuel Selbach2018-04-03

Actions
#1

Updated by Daniel Damm about 2 years ago

  • Related to Bug #84588: Int values for field will be converted to unix timestamp in module "DB check" -> Full search added
#2

Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Needs Feedback

Is this still present on 9.5.15 or latest master?

#3

Updated by Riccardo De Contardi over 1 year ago

I tried with 9.5.15 and EXT:news to build a query with sys_language_uid =-1:

the resulting query is:

SELECT `uid`, `title`, `teaser`, `pid`, `deleted` FROM `tx_news_domain_model_news` WHERE (tx_news_domain_model_news.sys_language_uid = '-1') AND (`tx_news_domain_model_news`.`deleted` = 0) LIMIT 100

#4

Updated by Josef Glatz over 1 year ago

  • Status changed from Needs Feedback to Closed

Can't reproduce this issue anymore in 10.4.1-dev

Also available in: Atom PDF