Bug #87873

SQL error while saving sys_file_storage with strict_type

Added by Stefan Froemken over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
Start date:
2019-03-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello Core-Team,

I have created my development environment in ddev container where MariaDB 10.2 is configured with strict_type on.

While saving a sys_file_storage record I get following error:

2: SQL error: 'Incorrect integer value: '' for column 'is_public' at row 1

For now I have deactivated strict_type, but I think it's up to you, to store the correct value.

Stefan

#1

Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60032

#2

Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60052

#3

Updated by Georg Ringer over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Gerrit Code Review over 2 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60072

#5

Updated by Georg Ringer over 2 years ago

  • Status changed from Under Review to Resolved
#6

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed
#7

Updated by DANIEL Rémy about 1 year ago

Hi

I have this error on a 9.5.14:

SQL error: 'Incorrect integer value: '' for column `xxx`.`sys_file_storage`.`is_public` at row 1' (sys_file_storage:2) (msg#1.2.12)

The TCA default for sys_file_storage.is_public is 1, so the issue is elsewhere.
Could it be the missing "items" definition? All the other "boolean" columns of this table have "items" but not "is_public".

        'is_online' => [
            'label' => 'LLL:EXT:core/Resources/Private/Language/locallang_tca.xlf:sys_file_storage.is_online',
            'config' => [
                'type' => 'check',
                'renderType' => 'checkboxToggle',
                'default' => 1,
                'items' => [
                    [
                        0 => '',
                        1 => '',
                    ]
                ],
            ]
        ],
        'is_public' => [
            'label' => 'LLL:EXT:core/Resources/Private/Language/locallang_tca.xlf:sys_file_storage.is_public',
            'config' => [
                'default' => 1,
                'type' => 'user',
                'renderType' => 'userSysFileStorageIsPublic',
            ]
        ],

Also available in: Atom PDF