Bug #87885

Content displayed is always the content of the first page

Added by Florian Rival 2 months ago. Updated about 2 months ago.

Status:
Needs Feedback
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2019-03-11
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have a strange behavior with Typo3 V9 and site_package extension with bootstrap, for all pages, the content displayed is always the content of the first page, the variable {data} in fluid templates is always set with first page instead of current page.

_.htaccess (19.6 KB) nachVORNE Medienagentur, 2019-03-13 14:51

config.yaml View (769 Bytes) nachVORNE Medienagentur, 2019-03-13 14:56

History

#1 Updated by Florian Rival 2 months ago

The problem was solved changing site configuration, clear cache and adding a site language.
I tried to identify the problem but seems to be unpredictable, I think some cache and something with "Entry point" and "Variant Entry Point".

A sample of my yaml config file :

rootPageId: 2
base: 'https://www.mysite.fr/'
baseVariants:
  -
    base: 'https://www.mysite.local'
    condition: 'applicationContext == "Development"'
languages:
  -
    title: Français
    enabled: true
    languageId: '0'
    base: /
    typo3Language: default
    locale: fr_FR.UTF8
    iso-639-1: fr
    navigationTitle: ''
    hreflang: fr-FR
    direction: ''
    flag: fr
errorHandling: {  }
routes: {  }

#2 Updated by Susanne Moog 2 months ago

  • Status changed from New to Closed

Closing as issue was solved by the reporter.

#3 Updated by Susanne Moog 2 months ago

  • Status changed from Closed to Needs Feedback

#4 Updated by nachVORNE Medienagentur 2 months ago

Experienced the same. I guess it has something to do with the language specific `base` part and the new routing:
My multi language, multi site TYPO3 system started to only show the root page of the first site's root page no matter what page I click on in navigation (correct links) or enter by hand. Same for translated pages (`/en`).
It all worked like a charm until I tried to globally remove the trailing slash from urls. I set a redirect in .htaccess and removed the trailing slash from `/en/` in site config for my second language in order to not run into endless redirects.
I somehow managed to ‘solve’ it on one website. I guess I solved it by changing my site config back and forth and clearing caches randomly. Unfortunately not happening like that this time.
  • Can reproduce the error
  • have an install where it worked and one where it doesn't
  • both where the same TYPO3 version 9.5.5
  • only difference of the one working and the one not is that the one not working is a multi site system.
  • both systems worked fine before starting to fiddle around with the `/en` and `/en/`
  • cleared all caches, even manually removed typo3temp subfolders and truncated all cache_* tables
  • tried both in Development and Production applicationContext

running on:
CentOS el7 (inside a vagrant on my machine and standalone on staging)
TYPO3 9.5.5
Apache + nginx reverse and ssl endpoint
PHP 7.2
MySQL 5.7

#5 Updated by Susanne Moog 2 months ago

nachVORNE Medienagentur wrote:

  • Can reproduce the error

Can you add your site configuration, redirect configuration (.htaccess) and maybe an example page tree structure (just written down)?

#6 Updated by nachVORNE Medienagentur 2 months ago

Added .htacces and the config.yaml for one of the pages.

page structure is the following:

[0] companyname
  [114] examplepage1 (isroot)
    - 2 dim of subpages here
  [65] examplepage2 (isroot)
    - 2 dim of subpages here
  [1] examplepage3 (isroot)
    - 2 dim of subpages here
  [18] Storage

#7 Updated by nachVORNE Medienagentur 2 months ago

I just realised:
my navigation and all content gets displayed in default language while language snippets in fluid are displayed from the translated (en) version.

{f:translate(key: 'LLL:templates/lang/lang.xml:contact.title')}

-> results in a "Contact" not "Kontakt" in my website head
In that xml file en is the 'default'.

So no language settings get applied. And the bug/fault might be found somewhere closer to that subject?

#8 Updated by nachVORNE Medienagentur 2 months ago

Figured out exactly at what moment that bug ocured!
When I added a https:// prefix to my Entry Points in site config.yaml!

What better way is there to force TYPO3 to always render https:// links?

#9 Updated by Susanne Moog 2 months ago

Can you try adding an ending slash to both the base and the language base? Example:

rootPageId: 10
base: 'https://ctm2.dev.local/'
baseVariants: {  }
languages:
  -
    title: English
    enabled: true
    languageId: '0'
    base: /
    typo3Language: default
    locale: en_US.UTF-8
    iso-639-1: ab
    navigationTitle: ''
    hreflang: ''
    direction: ''
    flag: global
  -
    title: German
    enabled: true
    languageId: '2'
    base: /de/
    typo3Language: default
    locale: de_DE.UTF-8
    iso-639-1: de
    navigationTitle: ''
    hreflang: ''
    direction: ''
    fallbackType: strict
    flag: de

#10 Updated by Florian Rival 2 months ago

It's the same for me, the bug appears when setting HTTPS protocol.

This configuration works (this is my first configuration) :

rootPageId: 1
base: 'http://www.MYSITE.fr/'
baseVariants:
  -
    base: 'http://www.MYSITE.local'
    condition: 'applicationContext == "Development"'
languages:
  -
    title: Français
    enabled: true
    languageId: '0'
    base: /
    typo3Language: fr
    locale: fr_FR.UTF8
    iso-639-1: fr
    navigationTitle: Français
    hreflang: fr-FR
    direction: ''
    flag: fr
errorHandling: {  }
routes: {  }

if I change it with HTTPS protocol (clear all cache and typo3temp dir also), it doesn't work anymore :

rootPageId: 1
base: 'https://www.MYSITE.fr/'
baseVariants:
  -
    base: 'https://www.MYSITE.local'
    condition: 'applicationContext == "Development"'
languages:
  -
    title: Français
    enabled: true
    languageId: '0'
    base: /
    typo3Language: fr
    locale: fr_FR.UTF8
    iso-639-1: fr
    navigationTitle: Français
    hreflang: fr-FR
    direction: ''
    flag: fr
errorHandling: {  }
routes: {  }

#11 Updated by Riccardo De Contardi about 2 months ago

  • Category set to Link Handling, Site Handling & Routing

#12 Updated by Benni Mack about 2 months ago

Hi @nachVorne Medienagentur.

Since you're using an SSL nginx endpoint for your site - did you configure your proxyServer Settings in TYPO3_CONF_VARS properly?

As we're dealing a lot with SSL endpoints and reverse proxies and lots of other levels, I'm very curious to know how your set up looks like and if your NGINX endpoint actually lets the apache2 server know that it's an SSL endpoint.

Thanks.
Benni.

Also available in: Atom PDF