Bug #87885

Content displayed is always the content of the first page

Added by Florian Rival 9 days ago. Updated 2 days ago.

Status:
Needs Feedback
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-03-11
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have a strange behavior with Typo3 V9 and site_package extension with bootstrap, for all pages, the content displayed is always the content of the first page, the variable {data} in fluid templates is always set with first page instead of current page.

_.htaccess (19.6 KB) nachVORNE Medienagentur, 2019-03-13 14:51

config.yaml View (769 Bytes) nachVORNE Medienagentur, 2019-03-13 14:56

History

#1 Updated by Florian Rival 9 days ago

The problem was solved changing site configuration, clear cache and adding a site language.
I tried to identify the problem but seems to be unpredictable, I think some cache and something with "Entry point" and "Variant Entry Point".

A sample of my yaml config file :

rootPageId: 2
base: 'https://www.mysite.fr/'
baseVariants:
  -
    base: 'https://www.mysite.local'
    condition: 'applicationContext == "Development"'
languages:
  -
    title: Français
    enabled: true
    languageId: '0'
    base: /
    typo3Language: default
    locale: fr_FR.UTF8
    iso-639-1: fr
    navigationTitle: ''
    hreflang: fr-FR
    direction: ''
    flag: fr
errorHandling: {  }
routes: {  }

#2 Updated by Susanne Moog 9 days ago

  • Status changed from New to Closed

Closing as issue was solved by the reporter.

#3 Updated by Susanne Moog 7 days ago

  • Status changed from Closed to Needs Feedback

#4 Updated by nachVORNE Medienagentur 7 days ago

Experienced the same. I guess it has something to do with the language specific `base` part and the new routing:
My multi language, multi site TYPO3 system started to only show the root page of the first site's root page no matter what page I click on in navigation (correct links) or enter by hand. Same for translated pages (`/en`).
It all worked like a charm until I tried to globally remove the trailing slash from urls. I set a redirect in .htaccess and removed the trailing slash from `/en/` in site config for my second language in order to not run into endless redirects.
I somehow managed to ‘solve’ it on one website. I guess I solved it by changing my site config back and forth and clearing caches randomly. Unfortunately not happening like that this time.
  • Can reproduce the error
  • have an install where it worked and one where it doesn't
  • both where the same TYPO3 version 9.5.5
  • only difference of the one working and the one not is that the one not working is a multi site system.
  • both systems worked fine before starting to fiddle around with the `/en` and `/en/`
  • cleared all caches, even manually removed typo3temp subfolders and truncated all cache_* tables
  • tried both in Development and Production applicationContext

running on:
CentOS el7 (inside a vagrant on my machine and standalone on staging)
TYPO3 9.5.5
Apache + nginx reverse and ssl endpoint
PHP 7.2
MySQL 5.7

#5 Updated by Susanne Moog 7 days ago

nachVORNE Medienagentur wrote:

  • Can reproduce the error

Can you add your site configuration, redirect configuration (.htaccess) and maybe an example page tree structure (just written down)?

#6 Updated by nachVORNE Medienagentur 7 days ago

Added .htacces and the config.yaml for one of the pages.

page structure is the following:

[0] companyname
  [114] examplepage1 (isroot)
    - 2 dim of subpages here
  [65] examplepage2 (isroot)
    - 2 dim of subpages here
  [1] examplepage3 (isroot)
    - 2 dim of subpages here
  [18] Storage

#7 Updated by nachVORNE Medienagentur 7 days ago

I just realised:
my navigation and all content gets displayed in default language while language snippets in fluid are displayed from the translated (en) version.

{f:translate(key: 'LLL:templates/lang/lang.xml:contact.title')}

-> results in a "Contact" not "Kontakt" in my website head
In that xml file en is the 'default'.

So no language settings get applied. And the bug/fault might be found somewhere closer to that subject?

#8 Updated by nachVORNE Medienagentur 5 days ago

Figured out exactly at what moment that bug ocured!
When I added a https:// prefix to my Entry Points in site config.yaml!

What better way is there to force TYPO3 to always render https:// links?

#9 Updated by Susanne Moog 2 days ago

Can you try adding an ending slash to both the base and the language base? Example:

rootPageId: 10
base: 'https://ctm2.dev.local/'
baseVariants: {  }
languages:
  -
    title: English
    enabled: true
    languageId: '0'
    base: /
    typo3Language: default
    locale: en_US.UTF-8
    iso-639-1: ab
    navigationTitle: ''
    hreflang: ''
    direction: ''
    flag: global
  -
    title: German
    enabled: true
    languageId: '2'
    base: /de/
    typo3Language: default
    locale: de_DE.UTF-8
    iso-639-1: de
    navigationTitle: ''
    hreflang: ''
    direction: ''
    fallbackType: strict
    flag: de

Also available in: Atom PDF