Bug #87912

XML sitemap with localised news records does not respect language

Added by Chris Müller 2 months ago. Updated 18 days ago.

Status:
Closed
Priority:
Must have
Category:
SEO
Target version:
Start date:
2019-03-14
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I am using the news aextension with localised records (e.g. English as default language and German as second language).

The different languages are available via

https://example.org/en/
https://example.org/de/

Now I defined an XML sitemap:

plugin.tx_seo {
    config {
        xmlSitemap {
            sitemaps {
                tx_news {
                    provider = TYPO3\CMS\Seo\XmlSitemap\RecordsXmlSitemapDataProvider
                    config {
                        table = tx_news_domain_model_news
                        sortField = uid
                        lastModifiedField = tstamp
                        additionalWhere =
                        pid = {$site.plugin.tx_news.storagePageId}
                        url {
                            pageId = {$site.plugin.tx_news.singlePageId}
                            fieldToParameterMap {
                                uid = tx_news_pi1[news]
                            }

                            additionalGetParameters {
                                tx_news_pi1.controller = News
                                tx_news_pi1.action = detail
                            }

                            useCacheHash = 1
                        }
                    }
                }
            }
        }
    }
}

When I call the generated XML sitemap for English, I got the URLs:
- https://example.org/en/article/english-text/
- https://example.org/en/article/german-text/

And for German:
- https://example.org/de/article/german-text/
- https://example.org/de/article/german-text/
with different modification dates

Both are the same news item, but localised.


Related issues

Related to TYPO3 Core - Bug #87841: Sitemap generation doesn't take request language into account Closed 2019-03-05

Associated revisions

Revision fceffe98 (diff)
Added by Richard Haeser 25 days ago

[BUGFIX] Only show records from current language in XML Sitemap

When generating the XML sitemap for records, the language of the
records will be checked. Only records from the current language or
all languages are added to the XML sitemap.

Resolves: #87912
Resolves: #87841
Releases: master, 9.5
Change-Id: Ibc2bc847840ff7ae6d34aa0b0b40fbe163ce2b78
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60629
Tested-by: TYPO3com <>
Tested-by: Soren Malling <>
Tested-by: Georg Ringer <>
Tested-by: Richard Haeser <>
Reviewed-by: Riny van Tiggelen <>
Reviewed-by: Soren Malling <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Richard Haeser <>

Revision ecccdc49 (diff)
Added by Richard Haeser 25 days ago

[BUGFIX] Only show records from current language in XML Sitemap

When generating the XML sitemap for records, the language of the
records will be checked. Only records from the current language or
all languages are added to the XML sitemap.

Resolves: #87912
Resolves: #87841
Releases: master, 9.5
Change-Id: Ibc2bc847840ff7ae6d34aa0b0b40fbe163ce2b78
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60633
Tested-by: TYPO3com <>
Tested-by: Riny van Tiggelen <>
Tested-by: Richard Haeser <>
Reviewed-by: Riny van Tiggelen <>
Reviewed-by: Richard Haeser <>

History

#1 Updated by Soren Malling 2 months ago

  • Related to Bug #87841: Sitemap generation doesn't take request language into account added

#2 Updated by Richard Haeser 2 months ago

If I'm correct, this is a duplicate of #87841?

#3 Updated by Richard Haeser 2 months ago

  • Status changed from New to Needs Feedback

#5 Updated by Richard Haeser about 1 month ago

  • Status changed from Needs Feedback to New

#6 Updated by Richard Haeser 26 days ago

  • Status changed from New to Accepted
  • Target version set to Candidate for patchlevel

#7 Updated by Gerrit Code Review 26 days ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60629

#8 Updated by Richard Haeser 25 days ago

  • Target version changed from Candidate for patchlevel to next-patchlevel

#9 Updated by Richard Haeser 25 days ago

  • Assignee set to Richard Haeser

#10 Updated by Gerrit Code Review 25 days ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60633

#11 Updated by Richard Haeser 25 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Gerrit Code Review 25 days ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60633

#13 Updated by Gerrit Code Review 25 days ago

Patch set 3 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60633

#14 Updated by Gerrit Code Review 25 days ago

Patch set 4 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60633

#15 Updated by Gerrit Code Review 25 days ago

Patch set 5 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60633

#16 Updated by Richard Haeser 25 days ago

  • Status changed from Under Review to Resolved

#17 Updated by Gerrit Code Review 25 days ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60634

#18 Updated by Richard Haeser 25 days ago

  • Status changed from Under Review to Resolved

#19 Updated by Gerrit Code Review 25 days ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60635

#20 Updated by Richard Haeser 25 days ago

  • Status changed from Under Review to Resolved

Sorry that this ticket number is wrongly used in other patches and is opening again every time.

#21 Updated by Benni Mack 18 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF