Bug #87965

Language arrangments in BE not adhering to site config.yaml structure

Added by Ezra Ter Linden 9 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-03-20
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

According to my quick conversation with Benni Mack on the issue, the buildup of language menu dropdowns as well as the column arrangement in the BE should be given by the structure of the site modules config.yaml. In the prior to 9.x TYPO3 version, the sort order of dorpdowns and language columns was based upon the title. Currently it would appear that the sorting is based upon 'languageId'

Please see attached screenshots.

Example from config.yaml

languages:
  -
    title: de_DE
    enabled: true
    languageId: '0'
    base: /de_DE/
    typo3Language: de
    locale: de_DE
    iso-639-1: de
    navigationTitle: Deutsch
    hreflang: de-DE
    direction: ltr
    flag: de
  -
    title: de_AT
    enabled: true
    languageId: '19'
    base: /de_AT/
    typo3Language: de
    locale: de_AT
    iso-639-1: de
    navigationTitle: German
    hreflang: de-AT
    direction: ltr
    fallbackType: fallback
    fallbacks: '0'
    flag: at
  -
    title: de_LU
    enabled: true
    languageId: '7'
    base: /de_LU/
    typo3Language: de
    locale: de_LU
    iso-639-1: de
    navigationTitle: ''
    hreflang: ''
    direction: ''
    fallbackType: strict
    flag: lu

Based upon the above example, the current resulting order is:

de_DE
de_LU
de_AT

whereas the desired results would become: (if sorted by title)

de_AT
de_DE
de_LU

Screen Shot 2019-03-20 at 13.51.35.png View (165 KB) Ezra Ter Linden, 2019-03-20 15:12

Screen Shot 2019-03-20 at 14.36.02.png View (166 KB) Ezra Ter Linden, 2019-03-20 15:12


Related issues

Related to TYPO3 Core - Bug #87942: List view - deault language flag and label set only with TSConfig Closed 2019-03-17

History

#1 Updated by Bastian Bringenberg 9 months ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • Category deleted (Content)
  • TYPO3 Version set to 9

Moved to correct Project.

#2 Updated by Georg Ringer 9 months ago

  • Category set to Backend User Interface
  • Status changed from New to Accepted

#3 Updated by Georg Ringer 9 months ago

  • Related to Bug #87942: List view - deault language flag and label set only with TSConfig added

#4 Updated by Benni Mack 8 months ago

  • Status changed from Accepted to Needs Feedback

Hey Ezra,

just tested this --- have you actually flushed the caches? It works in my case!

All the best,
Benni.

#5 Updated by Georg Ringer 4 months ago

  • Status changed from Needs Feedback to Closed

closing because of no feedback.

Also available in: Atom PDF