Bug #87998

Error handling on multidomain

Added by Bernhard Eckl 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2019-03-25
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

On my TYPO3 setup (8.7.24, realurl 2.5.0) I have a page not found handling like:
'pageNotFound_handling' => 'USER_FUNCTION:typo3conf/class.user_notfound.php:user_notFound->pageNotFound'

This works fine, but only on the first website. The others try to access a /404/ page on the website domain (one redirects to https://www.domain.com/404/, the others display the 404 page of the domain without redirect). If there is no 404 page, I get an error:
#1509296606: Failed to fetch error page "http://domain.de/404/", reason: Server error: `GET http://domain.de/404/` resulted in a `500 Internal Server Error` response: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR (truncated...) (More information)

Strange behaviour, but I can not find a misconfiguration, is this a bug? At first I had 'pageNotFound_handling' => '/404/', but this is commented out.

class.user_notfound.php View (2.59 KB) Bernhard Eckl, 2019-03-26 09:20

History

#1 Updated by Bernhard Eckl 6 months ago

The one domain with redirect gives a 303 status code.

#2 Updated by Benni Mack 6 months ago

  • Status changed from New to Needs Feedback

Hi Bernhard,

what exactly does your userfunction do?

#3 Updated by Bernhard Eckl 6 months ago

Hi Benni,
I have attached the file. I think it is not the userfunction, because even if I just do echo 'foo'; in the function, it is the same.

#4 Updated by Bernhard Eckl 6 months ago

This can be closed. I found an additional configuration in AdditionalConfiguration.php I made a few years ago. Sorry, my fault.

#5 Updated by Riccardo De Contardi 6 months ago

  • Status changed from Needs Feedback to Closed

Hi @Bernhard Eckl thank you for your kind and quick response;

Closing the issue as requested by the reporter.

If you think that this is the wrong decision or experience the issue again, please reopen it or open a new issue with a reference to this one, adding a step-by-step tutorial about how to reproduce the issue.

Thank you.

Also available in: Atom PDF