Bug #88057

Child record was not processed

Added by Sergio Catalá 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2019-04-02
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Latest TYPO3 dev-master
EXT:news 7.1.0

1) Create a folder in backend
2) Translate such folder into an alternative language (already defined in sites config/) in backend
3) Create default news record in default folder in pagetree. Insert inside that default record a content element of type "Text".
4) Localize that default news record using "List" module and clicking the flag for the alternative language.

Error "Child record was not processed" appears.

88057_list_module.png View (69.2 KB) Oliver Hader, 2019-04-03 18:22

Associated revisions

Revision 412308e4 (diff)
Added by Oliver Hader 2 months ago

[BUGFIX] Sanitize undefined TCA columns required for data integrity

TCA's 'ctrl' section allows to define several database columns that
shall be used to store according integrity information, such as the
current language or pointers to ancestors used during localization.

In case those names are not defined properly in TCA's 'columns'
section, several commands (like copy of localize) are executed,
but without actually maintaining these values in the database.

In order to ensure integrity, missing columns that are defined in
the 'ctrl' section but missing in the 'columns' section are applied
with the TCA type 'passthrough'. This applies to 'ctrl' properties

  • origUid
  • languageField
  • translationSource
  • transOrigPointerField

Resolves: #88057
Releases: master, 9.5
Change-Id: I39a28dc2e1eddafe6363b7dd633fd84968fc620f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60511
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Tested-by: Georg Ringer <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Benni Mack <>
Reviewed-by: Daniel Goerz <>
Reviewed-by: Georg Ringer <>

Revision 92af996e (diff)
Added by Oliver Hader about 2 months ago

[BUGFIX] Sanitize undefined TCA columns required for data integrity

TCA's 'ctrl' section allows to define several database columns that
shall be used to store according integrity information, such as the
current language or pointers to ancestors used during localization.

In case those names are not defined properly in TCA's 'columns'
section, several commands (like copy of localize) are executed,
but without actually maintaining these values in the database.

In order to ensure integrity, missing columns that are defined in
the 'ctrl' section but missing in the 'columns' section are applied
with the TCA type 'passthrough'. This applies to 'ctrl' properties

  • origUid
  • languageField
  • translationSource
  • transOrigPointerField

Resolves: #88057
Releases: master, 9.5
Change-Id: I39a28dc2e1eddafe6363b7dd633fd84968fc620f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60396
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Benni Mack <>

History

#1 Updated by Oliver Hader 3 months ago

  • File 88057_list_module.png View added
  • Category set to Database API (Doctrine DBAL)
  • Status changed from New to Needs Feedback

I could not reproduce the behavior you described with ext:news v7.1.0 and TYPO3 v9.5.x@dev (5133578a4e534873cf3777cc9c6c579076a45250).
ext:news is not compatible with TYPO3 dev-master v10.0.x@dev - a couple of exceptions are thrown on saving any news item - I guess, "dev-master" in the report refers to "latest 9.5".

#2 Updated by Oliver Hader 3 months ago

  • Category changed from Database API (Doctrine DBAL) to DataHandler aka TCEmain

#3 Updated by Sergio Catalá 3 months ago

Oliver, sorry, yes, I used 9.5.x@dev, that's what I meant.
Sorry, my step 3) was not properly described (I have a custom text element over my instance, which has IRRE relations).
Try this instead:
3) Create default news record in default folder in pagetree. Insert inside that default record TWO "Related links" inside tab "Relations".

It is important that there are at least two IRRE relations inside the record, because the error cannot be seen with just one IRRE relation.

#4 Updated by Oliver Hader 3 months ago

  • Status changed from Needs Feedback to Accepted

Fix for ext:news - https://github.com/georgringer/news/pull/890

The core could accept those system internal properties in case they were defined in ctrl section, but omitted in columns section of $TCA

#5 Updated by Gerrit Code Review 3 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60396

#6 Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60511

#7 Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60511

#8 Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60396

#9 Updated by Gerrit Code Review 2 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60511

#10 Updated by Gerrit Code Review 2 months ago

Patch set 3 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60396

#11 Updated by Oliver Hader 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Gerrit Code Review about 2 months ago

  • Status changed from Resolved to Under Review

Patch set 4 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60396

#13 Updated by Oliver Hader about 2 months ago

  • Status changed from Under Review to Resolved

#14 Updated by Benni Mack about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF