Bug #88377

Page tree delete does not perform error checking

Added by filigivuji filigivuji over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Running TYPO3 9.5.7.
Deleting a page via the page tree does not seem to perform error checking in this particular scenario, the page tree just reloads without the deletion being performed and without showing an error message:

  1. Create a page (lets call it page A) with a subpage.
  2. Make sure that in user settings -> Edit and Advanced functions -> "Recursive Delete(!): Allow ALL subpages to be deleted when deleting a page" is disabled. Should be default for new users.
  3. Right click on page A in the page tree and choose "Delete".

Expected behavior: An error message is shown.
Actual behavior: The page tree reloads without showing any error message. An error message is only shown when navigating to a new backend site ("Attempt to delete page which has subpages").

This bug may not be exclusive to this specific scenario when deleting pages via the context menu, I haven't checked whether other errors are properly handled.

This seems to be a regression. In TYPO3 6.2 in the same scenario, an error message notification pops up:

Exception
[1.0.-1]: [newlog()] Attempt to delete page which has subpages


Related issues

Related to TYPO3 Core - Bug #87416: Page is not deleted through the context menu if the site has translations and the page was currently selectedClosed2019-01-11

Actions
#1

Updated by filigivuji filigivuji over 2 years ago

  • Related to Bug #87416: Page is not deleted through the context menu if the site has translations and the page was currently selected added
#2

Updated by filigivuji filigivuji over 2 years ago

  • Subject changed from Page tree delete does not perform error checking (recursive deletion) to Page tree delete does not perform error checking

This issue is related to #87416, which was solved by implementing a change that uses AJAX to perform deletions. See this change set -- it is obvious that the AJAX call in the change does not perform any error checking at all. So the same bug (no error messages) probably applies to other situations as well, e.g. when deleting a page that was already deleted from another tab or trying to delete a page the user does not have the appropriate permission for.

I have tested the above scenario on 9.5.5 and the issue does not happen there as in the iframe a page is loaded which in turn shows the error message boxes immediately.

#3

Updated by Riccardo De Contardi over 2 years ago

This issue is still present on 9.5.9 and 10.1.0-dev (latest master)

#4

Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61954

#5

Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61966

#6

Updated by Andreas Fernandez over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Gerrit Code Review over 2 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61966

#8

Updated by Andreas Fernandez over 2 years ago

  • Status changed from Under Review to Resolved
#9

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF