Bug #87416

Page is not deleted through the context menu if the site has translations and the page was currently selected

Added by Stefanos Karasavvidis 11 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Pagetree
Target version:
Start date:
2019-01-11
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

1) have a site with translatable content
2) create a page
3) regardless of the type of user (admin or non admin), and regardless on whether there is or is not content on the page in any of the languages

a) having the page selected in the page tree and deleting it through the context menu, does not actually delete it. No error messages are shown. Regardless on whether you were in the page module or the list module.

b) having the page selected in the page tree, and deleting it through the "drag page to the right, red delete area", does delete it

c) having selected another page in the page tree, and deleting the page through the context menu, does delete it without problems

Observed on 9 and current master


Related issues

Related to TYPO3 Core - Bug #88377: Page tree delete does not perform error checking Resolved
Related to TYPO3 Core - Bug #88998: List view - context menu - delete does not update list view New 2019-08-22

Associated revisions

Revision 2407febb (diff)
Added by Andreas Fernandez 8 months ago

[BUGFIX] Invoke delete command via AJAX

The delete command triggered by the page tree's context menu was invoked
by loading a URL in the module iframe which caused timing issues due to
subsequent requests.

This patch invokes an AJAX call instead to deleted pages.

Resolves: #87416
Releases: master, 9.5
Change-Id: I457df1a21e703f98f6b1a182f6165f60cfd13b21
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60621
Tested-by: Josef Glatz <>
Tested-by: TYPO3com <>
Tested-by: Richard Haeser <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Richard Haeser <>

Revision bd5c47eb (diff)
Added by Andreas Fernandez 8 months ago

[BUGFIX] Invoke delete command via AJAX

The delete command triggered by the page tree's context menu was invoked
by loading a URL in the module iframe which caused timing issues due to
subsequent requests.

This patch invokes an AJAX call instead to deleted pages.

Resolves: #87416
Releases: master, 9.5
Change-Id: I457df1a21e703f98f6b1a182f6165f60cfd13b21
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60622
Tested-by: Richard Haeser <>
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Richard Haeser <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Ricky Mathew 11 months ago

  • Priority changed from Should have to Must have

Any updates?

#2 Updated by Thomas Off 11 months ago

I have the same problem, too.

#3 Updated by Riccardo De Contardi 11 months ago

  • Category set to Pagetree

#4 Updated by Ricky Mathew 9 months ago

  • Target version set to next-patchlevel

#5 Updated by André Schließer 9 months ago

I can reproduce it in the same way in 9.5 and master

#6 Updated by Richard Haeser 8 months ago

Can confirm this. I can even reproduce this without having translations in your website. So if you want to delete the page by the context menu that is currently selected, you get the earlier mentioned behaviour.

#7 Updated by Chris K. 8 months ago

Richard Haeser wrote:

Can confirm this. I can even reproduce this without having translations in your website. So if you want to delete the page by the context menu that is currently selected, you get the earlier mentioned behaviour.

Yes! By me it is the same. I can reproduce this with a clean TYPO3 9.5 Installation and without having translations.

#8 Updated by Andreas Fernandez 8 months ago

  • Status changed from New to In Progress

#9 Updated by Gerrit Code Review 8 months ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60621

#10 Updated by Gerrit Code Review 8 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60621

#11 Updated by Gerrit Code Review 8 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60622

#12 Updated by Andreas Fernandez 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#13 Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

#14 Updated by filigivuji filigivuji 7 months ago

  • Related to Bug #88377: Page tree delete does not perform error checking added

#15 Updated by Andreas Fernandez 4 months ago

  • Related to Bug #88998: List view - context menu - delete does not update list view added

Also available in: Atom PDF