Bug #88421

LanguageMenuProcessor is not providing flagIdentifier

Added by Alexander Stehlik about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2019-05-23
Due date:
% Done:

0%

TYPO3 Version:
10
PHP Version:
7.2
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

The LanguageMenuProcessor does not provide the flagIdentifier property of language configurations.

The flag information could be useful though for rendering flag icons for the language menu entries.


Related issues

Related to TYPO3 Core - Feature #84650: Introduce fluid data-processor for language menus Closed 2018-04-06

History

#1 Updated by Alexander Stehlik about 1 year ago

  • Related to Feature #84650: Introduce fluid data-processor for language menus added

#2 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60801

#3 Updated by Alexander Stehlik about 1 year ago

Will not be implemented. Usage of flags for languages is discouraged.

See feedback in Gerrit and Slack

Use hreflang for language / country combinations or one of the other identifiers if you need flags. You can also extend the LanguageMenuProcessor class in your site package.

#4 Updated by Andreas Fernandez about 1 year ago

  • Status changed from Under Review to Closed

#5 Updated by Georg Ringer about 1 year ago

Abandoned

Also available in: Atom PDF