Bug #88503

Delete placeholders are not considered in FormEngine TcaInline view anymore

Added by Oliver Hader almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2019-06-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Scenario:

  • backend
    • having some content element (text w/image)
    • having at least one image reference
  • switching to some workspace
    • edit same content element
    • delete one image reference
    • save form

Result:

  • deleted image reference is still visualized in FormEngine when in workspace context
  • delete placeholder actually is correctly persisted to database - thus, overlaying fails in a way

Versions:

  • works in TYPO3 v8 & v7
  • does not work in TYPO3 v9 anymore

Related issues

Related to TYPO3 Core - Bug #88046: RelationHandler does not respect deleted elementsClosed2019-04-01

Actions
Related to TYPO3 Core - Task #82634: Drop deprecated inline localizationModeClosed2017-10-02

Actions
Is duplicate of TYPO3 Core - Bug #88502: FormEngine IRRE does not work with WorkspacesClosedBenni Mack2019-06-06

Actions
#1

Updated by Oliver Hader almost 2 years ago

Introduces in https://review.typo3.org/c/Packages/TYPO3.CMS/+/52496/7/typo3/sysext/backend/Classes/Form/FormDataProvider/TcaInline.php#b154

$connectedUids = $this->getWorkspacedUids($connectedUids, $childTableName);

Processing version overlay is not done anymore in TYPO3 v9 (since v9.0.0)

#2

Updated by Oliver Hader almost 2 years ago

  • Related to Bug #88046: RelationHandler does not respect deleted elements added
#3

Updated by Oliver Hader almost 2 years ago

  • Related to Task #82634: Drop deprecated inline localizationMode added
#4

Updated by Oliver Hader almost 2 years ago

  • Is Regression set to Yes
#5

Updated by Oliver Hader almost 2 years ago

  • Subject changed from Delete placeholders are not considered in FormEngine anymore to Delete placeholders are not considered in FormEngine TcaInline view anymore
#6

Updated by Oliver Hader almost 2 years ago

  • Is duplicate of Bug #88502: FormEngine IRRE does not work with Workspaces added
#7

Updated by Oliver Hader almost 2 years ago

  • Status changed from New to Closed

Also available in: Atom PDF