Task #82634

Epic #80700: Remove deprecated code from the core

Drop deprecated inline localizationMode

Added by Christian Kuhn about 2 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-10-02
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Sprint Focus:

Related issues

Related to TYPO3 Core - Bug #88502: FormEngine IRRE does not work with Workspaces Resolved 2019-06-06
Related to TYPO3 Core - Bug #88503: Delete placeholders are not considered in FormEngine TcaInline view anymore Closed 2019-06-06
Related to TYPO3 Core - Bug #89418: FormEngine shows all possible IRRE elements Closed 2019-10-15

Associated revisions

Revision 20128778 (diff)
Added by Christian Kuhn about 2 years ago

[!!!][TASK] Remove inline localizationMode

Drop the TCA inline releated localizationMode settings.
This one has been deprecated with v8 including an
automatic TCA migration.

Change-Id: Ibb73721b188368605dd3cd75a29d2b7a8986966e
Releases: master
Resolves: #82634
Related: #80700
Reviewed-on: https://review.typo3.org/52496
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision db8d5dcb (diff)
Added by Benni Mack about 2 months ago

[BUGFIX] Ensure FormEngine IRRE handles relations in workspace

FormEngine does not show and handle IRRE records when they are
deleted (connected records from the live workspace are shown).

When removal and refactoring of code in this ares was done for
v9, "too much" code got removed. Which is why workspace overlays
are not handled properly anymore.

In addition, the ElementInformationController now correctly
resolves a workspace record when finding the pageInfo and access.

Resolves: #88502
Related: #82634
Releases: master, 9.5
Change-Id: Ib2d70ffa92c78752626b43ec5012d9dba036e7b8
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60890
Tested-by: TYPO3com <>
Tested-by: Achim Fritz <>
Tested-by: Daniel Goerz <>
Reviewed-by: Achim Fritz <>
Reviewed-by: Daniel Goerz <>

Revision be160136 (diff)
Added by Benni Mack about 2 months ago

[BUGFIX] Ensure FormEngine IRRE handles relations in workspace

FormEngine does not show and handle IRRE records when they are
deleted (connected records from the live workspace are shown).

When removal and refactoring of code in this ares was done for
v9, "too much" code got removed. Which is why workspace overlays
are not handled properly anymore.

In addition, the ElementInformationController now correctly
resolves a workspace record when finding the pageInfo and access.

Resolves: #88502
Related: #82634
Releases: master, 9.5
Change-Id: Ib2d70ffa92c78752626b43ec5012d9dba036e7b8
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61735
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Benni Mack <>

History

#1 Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52496

#2 Updated by Gerrit Code Review about 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52496

#3 Updated by Gerrit Code Review about 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52496

#4 Updated by Christian Kuhn about 2 years ago

  • Related to Epic #80700: Remove deprecated code from the core added

#5 Updated by Christian Kuhn about 2 years ago

  • Parent task set to #80700

#6 Updated by Gerrit Code Review about 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52496

#7 Updated by Christian Kuhn about 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

#9 Updated by Benni Mack 5 months ago

  • Related to Bug #88502: FormEngine IRRE does not work with Workspaces added

#10 Updated by Oliver Hader 5 months ago

  • Related to Bug #88503: Delete placeholders are not considered in FormEngine TcaInline view anymore added

#11 Updated by Oliver Hader 5 months ago

Regression since v9.0.0, see #88503

#12 Updated by Benni Mack 30 days ago

  • Related to Bug #89418: FormEngine shows all possible IRRE elements added

Also available in: Atom PDF