Project

General

Profile

Actions

Bug #88543

closed

Static routes does not work if no language serves root level

Added by Altan Tosun about 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2019-06-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In our configuration we've set all languages with a prefix (DE and EN).

We are using /de for German and /en for the English page.
In this case TYPO3 is redirecting every site which does not match to one of the prefixes (/de and /en) with a 307 to the default language ( /de which is fine so far).

The bug is that this behaviour happens also for static routes. In our case /robots.txt (defined as static route) is redirected to the /de page.

TYPO3 version: 9.5.7


Related issues 3 (2 open1 closed)

Related to TYPO3 Core - Bug #88902: Redirects are not resolved if there is a base path in default siteClosed2019-08-03

Actions
Related to TYPO3 Core - Feature #89518: Decouple static routes from site configUnder Review2019-10-25

Actions
Is duplicate of TYPO3 Core - Bug #86835: Static route sitemap.xml is still not working on single-page treeNew2018-11-02

Actions
Actions #1

Updated by Chris Müller about 5 years ago

  • Related to Bug #86835: Static route sitemap.xml is still not working on single-page tree added
Actions #2

Updated by Daniel Goerz almost 5 years ago

  • Related to Bug #88902: Redirects are not resolved if there is a base path in default site added
Actions #3

Updated by Daniel Goerz over 4 years ago

  • Status changed from New to Closed

Closed as a duplicate of https://forge.typo3.org/issues/86835

Actions #4

Updated by Daniel Goerz over 4 years ago

  • Related to Feature #89518: Decouple static routes from site config added
Actions #5

Updated by Daniel Goerz over 4 years ago

  • Related to deleted (Bug #86835: Static route sitemap.xml is still not working on single-page tree)
Actions #6

Updated by Daniel Goerz over 4 years ago

  • Is duplicate of Bug #86835: Static route sitemap.xml is still not working on single-page tree added
Actions

Also available in: Atom PDF