Project

General

Profile

Actions

Bug #88699

closed

Language Synchronization does not work in workspaces

Added by Sebastian Michaelsen about 5 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2019-07-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When editing a record which has translations, the \TYPO3\CMS\Core\DataHandling\Localization\DataMapProcessor loads those translations so columns can be synchronized if configured accordingly. That works fine in the Live Workspace but does not work in a workspace environment.

Consider the following news records:

uid l10n_parent t3ver_wsid t3ver_oid author
1 0 0 0 Anna
2 1 0 0 Anna
3 0 42 1 Anna

2 is a translation of 1. 3 is a workspace version of 1. author is configured to be synchronized between translations.

When 1 is changed then 2 is correctly synchronized.

When 3 is changed there is no record to load for synchronization.

So when I change author to "Bob" in 3 nothing is synchronized and when I publish the workspace I end up with 1 and 2 having different authors which should never be the case.

My suggestion would be that when 3 is changed, a workspace version of its translation has to be created on demand so the changes can be synchronized.


Files

cattura.png (105 KB) cattura.png Riccardo De Contardi, 2020-03-21 18:46
Actions #1

Updated by Sebastian Michaelsen about 5 years ago

  • Description updated (diff)
Actions #2

Updated by Riccardo De Contardi over 4 years ago

This issue seems still present on TYPO3 10.4.0-dev (latest master)

My test:

Prerequisistes

TYPO3 with two languages configured (ITA=default; ENG=id=1)
TYPO3 with a "Draft" workspace configured

Test execution

1) Create a "Test" page and translate it into "Test ENG"
2) Edit "Test" in default language > Tab "Metadata" > Field [author] > write in it "Maria", save
3) Open the translated "Test ENG" page > Tab "Metadata"

Result:

The default "Translation Behavior" is "Value of default language", so the field contains "Maria"

4) switch to "Draft" Workspace
5) Edit "Test" page in default language > Tab "Metadata" > Field [author] > change it to "Joht", save
6) Open translated page "Test ENG" since in workspace

Results:

The translated [author] value is still "Maria", see attached screenshot

It seems also that the two values will remain different even after publishing the Draft version to Live.

Actions #3

Updated by Sebastian Michaelsen 5 months ago

  • TYPO3 Version changed from 8 to 11

It is also still present in TYPO3 v11. I will soon recheck in v12. If the patch we're using still applies for 12 and 13 I will try to contribute it.

Actions #4

Updated by Riccardo De Contardi 4 months ago

  • Status changed from New to Needs Feedback

I am not able to reproduce this issue on 11.5.35, 12.4.11 and the latest main 13.1.0-dev using the procedure I described on my comment 2.

Prerequisistes

TYPO3 with two languages configured (ITA=default; ENG=id=1)
TYPO3 with a "Draft" workspace configured

Test execution

1) Create a "Test" page and translate it into "Test ENG"
2) Edit "Test" in default language > Tab "Metadata" > Field [author] > write in it "Maria", save
3) Open the translated "Test ENG" page > Tab "Metadata"

Result:

The default "Translation Behavior" is "Value of default language", so the field contains "Maria"

4) switch to "Draft" Workspace
5) Edit "Test" page in default language > Tab "Metadata" > Field [author] > change it to "John", save
6) Open translated page "Test ENG" still in "Draft" workspace

Results:

The translated [author] value is "John"

Am I missing something or is a different test necessary?

Actions #5

Updated by Sebastian Michaelsen 4 months ago

  • Status changed from Needs Feedback to Closed

I can confirm that the issue is fixed. I'm not sure by what. But I will close it. Thanks for the input @Riccardo De Contardi

Actions

Also available in: Atom PDF