Project

General

Profile

Actions

Bug #88719

closed

Close should recognize non-saved record - but fails

Added by Gone With the Wind about 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Start date:
2019-07-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
save-and-close
Complexity:
Is Regression:
Sprint Focus:

Description

After having assigned a target page to a shortcut page, the "Close" button should recognise that there was a change and therefore open a modal offering various editing option ("continue editing", "save and close" ...).

But in this case TYPO3 just closes the page without saving.

This is incoherent behaviour and should be matched to the procedure known from editing content elements.

Example to reproduce:

1. Create a new Shortcut page
2. Create a new nested Standard page
3. Go to the Shortcut and choose "edit page"
4. Assign the new Standard page as target
5 Click "Close"

Expected behaviour:
A modal opens with options how to continue editing

What really happens:
TYPO3 just closes the page with saving and without opening a modal.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #86611: TYPO3 does not ask, if changed but unsaved "Shortcut Target" should be savedClosed2018-10-09

Actions
Related to TYPO3 Core - Bug #88875: Modal Page altered not shown everytimeClosed2019-08-01

Actions
Actions #1

Updated by Riccardo De Contardi almost 5 years ago

  • Related to Bug #86611: TYPO3 does not ask, if changed but unsaved "Shortcut Target" should be saved added
Actions #2

Updated by Riccardo De Contardi almost 5 years ago

  • Related to Bug #88875: Modal Page altered not shown everytime added
Actions #3

Updated by Riccardo De Contardi over 4 years ago

  • Status changed from New to Needs Feedback

I think that this one has been solved on version 9 and 10

My tests:

Test 1

1) Create a new shortcut page
2) Assign as target an existing standard page
3) Click Close instead of Save

Result: the modal window that asks whether the page should be saved appears.

Test 2

1) Save the previous shortcut
2) Open the previous shortcut page
3) Select another existing standard page
4) Click Close instead of Save

Result: the modal window that asks whether the page should be saved appears.

Is this sufficient? Am I forgetting something?

Actions #4

Updated by Gone With the Wind over 4 years ago

Just tested in again on a 9.5.10 instance and can confirm that the behaviour is working as expected now.
Thank you!

Actions #5

Updated by Björn Jacob over 4 years ago

  • Status changed from Needs Feedback to Closed

Since the issue does not exist anymore, the issue can be closed. Thanks for taking care.

Actions

Also available in: Atom PDF