Bug #88875

Modal Page altered not shown everytime

Added by Pascal Querner 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2019-08-01
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
backend wizard modal
Complexity:
Is Regression:
Sprint Focus:

Description

When you alter data in a CE and leave the CE via "Close" button, it shows a modal with "You have unsaved changes, would you like to save and close, continue editing, or discard them".

However, this is not always shown.

So far I have not identify when it shows and when not, however It works on some flexform fields and on some it doesnt.
For instance the ext:news (version 7.2.0) adds a flexform field "Max width for media elements" for FE Plugin "List of selected items". If you enter data in there and decide to close the CE, it shows the modal.

If you enter data via the wizard for the field "PageId for single news display" however, the modal is not shown and you simply silently discard the changes to the plugin - leaving the CE without saving.

So my best guess its some kind of flexform wizard thing maybe.

Tested versions:
Standard ext:news 7.2.0
TYPO3 9.5.8
nginx-fpm with php 7.2.19


Related issues

Related to TYPO3 Core - Bug #86611: TYPO3 does not ask, if changed but unsaved "Shortcut Target" should be saved Needs Feedback 2018-10-09
Related to TYPO3 Core - Bug #88719: Close should recognize non-saved record - but fails New 2019-07-11
Related to TYPO3 Core - Bug #87385: No "Do you want to close without saving?" warning if changing date/time fields Accepted 2019-01-10
Related to TYPO3 Core - Bug #88776: RTE field in flexform is not detected as "dirty" when close element New 2019-07-16
Related to TYPO3 Core - Bug #88978: Close CE "Text & Media" after maximize and change won't save New 2019-08-20
Related to TYPO3 Core - Bug #88789: Include basis template dos not respect change on new record New 2019-07-17
Duplicated by TYPO3 Core - Bug #86922: Save modal does not appear for some input types Closed 2018-11-14

Associated revisions

Revision 35c8bd81 (diff)
Added by Andreas Fernandez 2 months ago

[BUGFIX] Mark fields as changed after updating value via ElementBrowser

With this patch, fields are now marked as changed when their value is
updated by using the Element Browser.

Resolves: #88875
Releases: master, 9.5
Change-Id: Ia39d080cfff538100c45561d8492c745c76388e7
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61450
Tested-by: TYPO3com <>
Tested-by: Josef Glatz <>
Tested-by: Frank Naegler <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Frank Naegler <>

Revision 7b4744a8 (diff)
Added by Andreas Fernandez 2 months ago

[BUGFIX] Mark fields as changed after updating value via ElementBrowser

With this patch, fields are now marked as changed when their value is
updated by using the Element Browser.

Resolves: #88875
Releases: master, 9.5
Change-Id: Ia39d080cfff538100c45561d8492c745c76388e7
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61456
Tested-by: TYPO3com <>
Tested-by: Josef Glatz <>
Tested-by: Frank Naegler <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Frank Naegler <>

History

#1 Updated by Riccardo De Contardi 2 months ago

  • Related to Bug #86611: TYPO3 does not ask, if changed but unsaved "Shortcut Target" should be saved added

#2 Updated by Riccardo De Contardi 2 months ago

  • Related to Bug #88719: Close should recognize non-saved record - but fails added

#3 Updated by Riccardo De Contardi 2 months ago

  • Related to Bug #87385: No "Do you want to close without saving?" warning if changing date/time fields added

#4 Updated by Riccardo De Contardi 2 months ago

  • Related to Bug #88776: RTE field in flexform is not detected as "dirty" when close element added

#5 Updated by Tobias Gaertner 2 months ago

So far it seems to be related only to flexform fields with a wizard like
  • RTE
  • PageID-Wizard
  • DateTime

Is this list complete? Can anyone confirm that behaveior?

#6 Updated by Riccardo De Contardi 2 months ago

In fact, the "shortcut target" mentioned on #86611 is solved, the issue mentions other two places where this problem occurs:

1) [...] removing a record from a multi select field. E.g. wehn I remove a static template from a sys_template record.
2) edit the content of some RTE text in "source code" mode and then hit close without saving

#7 Updated by Susanne Moog 2 months ago

  • Target version set to next-patchlevel

#8 Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61450

#9 Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61456

#10 Updated by Andreas Fernandez 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Daniel Siepmann about 2 months ago

  • Duplicated by Bug #86922: Save modal does not appear for some input types added

#12 Updated by Riccardo De Contardi about 2 months ago

  • Related to Bug #88978: Close CE "Text & Media" after maximize and change won't save added

#13 Updated by Riccardo De Contardi about 2 months ago

  • Related to Bug #88789: Include basis template dos not respect change on new record added

Also available in: Atom PDF