Bug #88789

Include basis template dos not respect change on new record

Added by Christian Tauscher about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend JavaScript
Target version:
-
Start date:
2019-07-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Create a New template record.

fill in a name - its required. Click on Close.

-> requester gives warning - OK. Save the record

(Open the Record again).
In field "Include basis template" add a Record

Click on the Close button
-> Even the record has been changed, the record will be closed without warning.

If the record has already a record saved, it works like expected.

Thanks for taking care about this

Christian.


Related issues

Related to TYPO3 Core - Bug #88875: Modal Page altered not shown everytimeClosed2019-08-01

Actions
#1

Updated by Daniel Windloff about 2 years ago

Can be reproduced on current master.

The column "basedOn", table "sys_template" (type=group) does not set class "has-change" for "Browse for records" and "Add New Basis Template".

#2

Updated by Riccardo De Contardi almost 2 years ago

  • Related to Bug #88875: Modal Page altered not shown everytime added
#3

Updated by Riccardo De Contardi almost 2 years ago

This issue

I tried the following tests on 9.5.9

Prerequisites:

- On a sysfolder > list view > create a new template record
- Add a title ("AAAAA"), click on "Save and Close".

Test 1

1) Open the template record "AAAAA"
1.1) Tab "Includes" > field Include Basis Template [basedOn] > click on the "+" icon ("Add New Basis Template") to add a new template
2) fill in a title "BBBBB" for the new created template, save and close it
2.1) Now the "BBBBB" template is listed on the list Include Basis Template [basedOn]
3) Click on Close

Actual result

- The template "AAAAA" is closed
- The "BBBBB" template has been include, this means that the "AAAAA" template change has been saved without confirmation

Expected result

- The "Do you want to close without saving?" modal should be shown

Test 2

1) same sysfolder > list view > create a new template record "CCCCC"
1.1) Save it and close
2) Open the template record "AAAAA"
2.1) Tab "Includes" > field Include Basis Template [basedOn] > click on the "folder" icon ("Browse for records") to add an existing template
2.2) Select "CCCCC"
2.3) Now the "CCCCC" template is listed on the list Include Basis Template [basedOn]
3) Click on Close

Actual result

- The "Do you want to close without saving?" modal is shown

Test 3

1) same sysfolder > list view > open the template record "AAAAA"
2) Tab "Includes" > field Include Basis Template [basedOn]
2.1) the list shows both "BBBBB" and "CCCCC" templates
2.2) Select one of the templates
3) Click on the arrows icons (e.g. "Move selected items upwards") and alter the order of the templates
4) Click on Close

Actual result

- The "Do you want to close without saving?" modal is shown

Test 4

1) same sysfolder > list view > open the template record "AAAAA"
2) Tab "Includes" > field Include Basis Template [basedOn]
2.1) the list shows both "BBBBB" and "CCCCC" templates
2.2) Select one of the templates
3) Click on the delete icon ("Remove selected items")
4) Click on Close

Actual result

- The "Do you want to close without saving?" modal is shown

Conclusion:

- the issue only affects the "+" button ("Add New Basis Template")

#4

Updated by Andreas Fernandez over 1 year ago

  • Status changed from New to Closed

I cannot reproduce the reported issue.

@Riccardo: You won't get a notification on close when adding a new basis template (BBBBB) because on save of that new template it's automatically assigned to AAAAA.

Also available in: Atom PDF