Bug #88989

Translations partially broken in EXT:felogin

Added by Matthias Krappitz 4 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2019-08-21
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:

Description

Probably due to language label renaming (removal of "ll_" prefixes) for TYPO3 10 in EXT:felogin now the translations for EXT:felogin for TYPO3 9 (and probably below) are broken.

Example of code in EXT:felogin/Classes/Controller/FrontendLoginController.php line 296 in TYPO3 9.5.9:

$markerArray['###DATA_LABEL###'] = htmlspecialchars($this->pi_getLL('ll_enter_your_data'));

But the translation server now serves this and other EXT:felogin labels in for example typo3conf/l10n/de/felogin/Resources/Private/Language/de.locallang.xlf without the "ll_" prefix:

<trans-unit id="enter_your_data" approved="yes">
    <source>Username or email address</source>
    <target state="translated">Benutzername oder E-Mail-Adresse</target>
</trans-unit>

This results in many labels remaining always english in all translated languages and you have mixed languages in the frontend.


Related issues

Related to TYPO3 Core - Task #88706: Streamline keys of locallang.xlf Closed 2019-07-09
Related to TYPO3 Core - Bug #89062: Some core translations for German missing in BE of TYPO3 9.5 Resolved 2019-09-02

History

#1 Updated by Helge Funk 4 months ago

  • Related to Task #88706: Streamline keys of locallang.xlf added

#2 Updated by Sybille Peters 3 months ago

  • Related to Bug #89062: Some core translations for German missing in BE of TYPO3 9.5 added

#3 Updated by Frank Naegler 2 months ago

  • Status changed from New to Needs Feedback

the issue should be solved since #89062 is fixed, can you confirm that it is fixed for you too?

#4 Updated by Thomas Luzat 2 months ago

Having had the same problem, I can confirm that the correct translation files are now loaded with the correct keys for felogin (and other components).

#5 Updated by Riccardo De Contardi about 2 months ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (Candidate for patchlevel)

I think it is safe to close this one as solved with #89062

If you think that this is the wrong decision please reopen it or ping me.

Also available in: Atom PDF