Bug #89062

Some core translations for German missing in BE of TYPO3 9.5

Added by Sybille Peters 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2019-09-02
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
translation
Complexity:
Is Regression:
Sprint Focus:

Description

Missing translations:

  • Filelist -> "Dateiliste"
  • pagelist context menu: Show, Edit, Info, Copy, Cut ...
  • BE module "Maintenance" and content within
  • BE module "Site Configuration"
  • etc.

Existing translations (as shown in BE):

  • all modules in WEB (e.g. File ("Seite"), View ("Anzeigen"), etc.)
  • module ADMIN TOOLS -> Extensions ("Erweiterungen")
  • all modules in SYSTEM

Another installation with TYPO3 9 upgrade performed a while ago has more translations, (though it is still missing translations for BE modules "Sites" and "Redirects" and cards in "Maintenance"). Also, everything in Maintenance still shows English texts). "Manage Language Packs" for inst2 shows "22.08.19 15:18" as time of last update.

backend-l10n-de.zip (11.8 KB) Sascha Maier, 2019-09-03 18:12


Related issues

Related to TYPO3 Core - Bug #88952: Translation of filelist broken. In Progress 2019-08-12
Related to TYPO3 Core - Bug #88989: Translations partially broken in EXT:felogin Closed 2019-08-21
Related to TYPO3 Core - Bug #89095: Language Packs for 10 are not available Resolved 2019-09-05
Related to TYPO3 Core - Bug #89099: Backend language files missing / German backend incomplete Closed 2019-09-06
Duplicated by TYPO3 Core - Bug #89230: Incomplete translation typo3 in french Closed 2019-09-23

History

#1 Updated by Sybille Peters 2 months ago

Is there a way to force the downloading of language packs? I saw in the other issue (#88952) that there was a problem.

#2 Updated by Sascha Maier 2 months ago

Don't know if this leading to the soluion. Seems the content of the downloaded zip changed:
old installations:
/var/labels/de/backend/Resources/Private/Language:
de.locallang_alt_doc.xlf de.locallang_pages_sort.xlf
de.locallang_db_new_content_el.xlf de.locallang_show_rechis.xlf
de.locallang_layout.xlf de.locallang_siteconfiguration_module.xlf
de.locallang_login.xlf de.locallang_siteconfiguration_tca.xlf
de.locallang_mod_help_cshmanual.xlf de.locallang_siteconfiguration.xlf
de.locallang_mod.xlf de.locallang_view_help.xlf
de.locallang_pages_new_csh.xlf de.locallang.xlf
de.locallang_pages_new.xlf de.siteconfiguration_fieldinformation.xlf
de.locallang_pages_sort_csh.xlf

new installed and updated language file:
/var/lang/backend/Resources/Private/Language
de.locallang_db_new_content_el.xlf de.locallang_mod.xlf
de.locallang_layout.xlf de.locallang.xlf

attached currently downloaded file. Downloadurl was: https://typo3.org/fileadmin/ter/b/a/backend-l10n/backend-l10n-de.v9.zip.

#3 Updated by Georg Ringer 2 months ago

FYI: the install tool sections are not translatable currently. but yes it seems there are some severe issues packing translations, see also slack channel #typo3-translations

#4 Updated by Georg Ringer 2 months ago

  • Status changed from New to Accepted

#5 Updated by Sybille Peters 2 months ago

I can confirm: In the TYPO3 9 installation that was previously updated and which has more translations, I have "Weitere Optionen..." as translation for "More options..." in the context menu and I can find this string in typo3temp:

 grep -r "\"Weitere Optionen...\"" typo3temp/var/cache/data/l10n

This is missing in the downloaded zip file from https://typo3.org/fileadmin/ter/b/a/backend-l10n/backend-l10n-de.v9.zip. I fetched another copy just now.

#6 Updated by Sybille Peters 2 months ago

  • Related to Bug #88952: Translation of filelist broken. added

#7 Updated by Sybille Peters 2 months ago

  • Related to Bug #88989: Translations partially broken in EXT:felogin added

#8 Updated by Georg Ringer 2 months ago

  • Related to Bug #89095: Language Packs for 10 are not available added

#9 Updated by Sybille Peters 2 months ago

As workaround: Some language files contain only a:0:{}. So I could do something like the following to copy the language files from another system (no guarantee this will safely work):

For typo3temp:

cd typo3temp
grep -rl "a:0:{}" var/cache/data/l10n/ | while read i;do echo "i=$i";cp OTHER-TYPO-SYSTEM-WITH-COMPLETE-LANGUAGE-FILES/typo3temp/$i $i;done

Some translation texts now reappear, e.g. "Weitere Optionen" and "Dateiliste".

Files in typo3temp will get overwritten. To permanently repair, you must replace files in typo3conf/l10n/de

#10 Updated by Chris K. about 2 months ago

  • Related to Bug #89099: Backend language files missing / German backend incomplete added

#11 Updated by Sybille Peters about 2 months ago

  • Subject changed from Upgrade to version 9.5.9: some core translations for German missing in BE to Some core translations for German missing in BE of TYPO3 9.5.9
  • Description updated (diff)

#12 Updated by Thomas Winkler about 2 months ago

Just to make clear it's not just happening in 9.5.9 but also in 9.5.8 (eventually 9.5.X or more versions).
This might be a bug in the server which is holding the langusge files and not of Typo3 itself?
Because before it worked in 9.5.8 and now it doesn't work anymore without changing the Typo3 installation.

#13 Updated by Sybille Peters about 2 months ago

Just to make clear it's not just happening in 9.5.9 but also in 9.5.8 (eventually 9.5.X or more versions). This might be a bug in the server which is holding the langusge files and not of Typo3 itself? Because before it worked in 9.5.8 and now it doesn't work anymore without changing the Typo3 installation.

Yes, see also comment by others and Georg Ringer. This wasn't clear to me when I wrote the bug report but I already changed the title.

#14 Updated by Sybille Peters about 2 months ago

  • Subject changed from Some core translations for German missing in BE of TYPO3 9.5.9 to Some core translations for German missing in BE of TYPO3 9.5

#15 Updated by Georg Ringer about 2 months ago

  • Duplicated by Bug #89230: Incomplete translation typo3 in french added

#16 Updated by Georg Ringer about 1 month ago

  • Status changed from Accepted to Resolved

everything should be back to normal again! if something is missing, please open an issue including the following information:

  • TYPO3 version
  • language downloaded
  • path to original xlf file + label

Also available in: Atom PDF