Bug #88998

Story #82206: list module enhancements/bugfixes

List view - context menu - delete does not update list view

Added by Riccardo De Contardi about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-08-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Prerequisites

Typo3 v.9 or v.10

Steps to reproduce

  1. go to list view
  2. select a table with two or more items (I tested it with pages, content, fe_users, be_users, templates)
  3. click on the icon of one item > bring the context menu
  4. select delete
  5. confirm the action

Expected results

- the item is deleted
- the list view is updated

Actual result

- the item is actually deleted, BUT
- it is still shown on the list view (the view is not updated - you have to click again on list module to see some difference)

Additional information

- No JavaScript error is thrown AFAICS
- The issue is absent on TYPO3 8, only affects 9 and 10.


Related issues

Related to TYPO3 Core - Bug #87416: Page is not deleted through the context menu if the site has translations and the page was currently selectedClosed2019-01-11

Actions
Related to TYPO3 Core - Bug #90791: Views are not updated after deleting records via context menuClosed2020-03-20

Actions
#1

Updated by Andreas Fernandez about 2 years ago

  • Related to Bug #87416: Page is not deleted through the context menu if the site has translations and the page was currently selected added
#2

Updated by Riccardo De Contardi over 1 year ago

  • Related to Bug #90791: Views are not updated after deleting records via context menu added
#3

Updated by Riccardo De Contardi over 1 year ago

This issue is solved on 10.4.0-dev (latest master), I think with https://review.typo3.org/c/Packages/TYPO3.CMS/+/63811

#4

Updated by Benni Mack over 1 year ago

  • Status changed from New to Closed

Also available in: Atom PDF