Project

General

Profile

Actions

Bug #89041

closed

GridDataService::generateDataArray missing pid in record data

Added by Frank Nägler over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
Start date:
2019-08-29
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

With #89008 the GridDataService changed and use the PID of a record in case the table is tt_content, but the records do not contain the PID.
this issue exists only in master, for v9 the problem was found before the merge happens.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Task #89008: Migrate TYPO3/CMS/Workspace/* to TypeScriptClosed2019-08-23

Actions
Related to TYPO3 Core - Bug #89050: Missing icon if only content elements are staged for changesClosed2019-08-30

Actions
Actions #1

Updated by Frank Nägler over 4 years ago

  • Related to Task #89008: Migrate TYPO3/CMS/Workspace/* to TypeScript added
Actions #2

Updated by Gerrit Code Review over 4 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61574

Actions #3

Updated by Frank Nägler over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #4

Updated by Andreas Kienast over 4 years ago

  • Related to Bug #89050: Missing icon if only content elements are staged for changes added
Actions #5

Updated by Benni Mack about 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF