Task #89110

Fluid 2.6.2 is released and should be required

Added by Claus Due 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2019-09-08
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
gremlin
Complexity:
Sprint Focus:

Description

Dependency should be updated to include workarounds for regular expression platform differences (regression in PCRE -> readline).

Associated revisions

Revision 685a3f78 (diff)
Added by Claus Due about 2 months ago

[TASK] Update Fluid engine to 2.6.4

Addresses the following issues:

  • Fixes an annotation that makes phpdocumentor/reflection-docblock
    throw exceptions in TYPO3v10.
  • Removes deprecation warning from composer due
    to incorrectly cased package name.
  • Fixes issues with binary characters in compiled templates.
  • Supports overloaded methods for variable extraction.
  • Avoids signature issues with CompileWithRenderStatic.
  • Works around PCRE regression issues on affected platforms.

Change-Id: I2b766ccc9bf3eaae77b1dfc1a73e9acc2a88d8a9
Resolves: #89110
Releases: master, 9.5, 8.7
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61642
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Anja Leichsenring <>

Revision e6b75640 (diff)
Added by Anja Leichsenring about 2 months ago

[TASK] Update Fluid engine to 2.6.4

Addresses the following issues:

  • Fixes an annotation that makes phpdocumentor/reflection-docblock
    throw exceptions in TYPO3v10.
  • Removes deprecation warning from composer due
    to incorrectly cased package name.
  • Fixes issues with binary characters in compiled templates.
  • Supports overloaded methods for variable extraction.
  • Avoids signature issues with CompileWithRenderStatic.
  • Works around PCRE regression issues on affected platforms.

Change-Id: I2b766ccc9bf3eaae77b1dfc1a73e9acc2a88d8a9
Resolves: #89110
Releases: master, 9.5, 8.7
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61782
Tested-by: TYPO3com <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Anja Leichsenring <>

Revision c08f3f94 (diff)
Added by Anja Leichsenring about 2 months ago

[TASK] Update Fluid engine to 2.6.4

Addresses the following issues:

  • Fixes an annotation that makes phpdocumentor/reflection-docblock
    throw exceptions in TYPO3v10.
  • Removes deprecation warning from composer due
    to incorrectly cased package name.
  • Fixes issues with binary characters in compiled templates.
  • Supports overloaded methods for variable extraction.
  • Avoids signature issues with CompileWithRenderStatic.
  • Works around PCRE regression issues on affected platforms.

Change-Id: I2b766ccc9bf3eaae77b1dfc1a73e9acc2a88d8a9
Resolves: #89110
Releases: master, 9.5, 8.7
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61783
Tested-by: TYPO3com <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Anja Leichsenring <>

History

#1 Updated by Claus Due 2 months ago

  • Category set to Fluid

#2 Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61642

#3 Updated by Claus Due 2 months ago

2.6.4 is released which addresses one additional issue with TYPO3v10 because of phpdocumentor/reflection-docblock.

#4 Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61642

#5 Updated by Gerrit Code Review 2 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61642

#6 Updated by Gerrit Code Review 2 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61642

#7 Updated by Gerrit Code Review 2 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61642

#8 Updated by Gerrit Code Review 2 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61642

#9 Updated by Gerrit Code Review about 2 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61642

#10 Updated by Gerrit Code Review about 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61782

#11 Updated by Anonymous about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Gerrit Code Review about 2 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61783

#13 Updated by Anja Leichsenring about 2 months ago

  • Status changed from Under Review to Resolved

#14 Updated by Oliver Hader about 1 month ago

  • Tags set to gremlin

Also available in: Atom PDF