Task #89220

Revert value of input if confirmation modal is not accepted

Added by Harald Atteneder about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-09-21
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
easy
Sprint Focus:

Description

When changing the doktype a confirmation modal appears. After closing the modal without clicking OK the new value is still selected. To improve UX it would be better to revert to the previous value.


Related issues

Related to TYPO3 Core - Feature #34624: Changing the type field of a new element should not result in saving Accepted 2012-03-07
Related to TYPO3 Core - Feature #89361: Changing 'onChange' => 'reload' behavior New 2019-10-07
Related to TYPO3 Core - Task #89362: Revert changed backend behavior for onChange/type Closed 2019-10-07

Associated revisions

Revision b5734b00 (diff)
Added by Harald Atteneder about 1 year ago

[TASK] Keep old value on confirmation modal close

When changing the doktype a confirmation modal appears. This patch
reverts the value of the field to the original value after closing the
modal without clicking OK.

This works for all selects with 'onChange' => 'reload' and
'renderType' => 'selectSingle'

Resolves: #89220
Releases: master,9.5
Change-Id: I6d479f9180d64e8e4c25e96f52e60dca36863fd9
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771
Tested-by: TYPO3com <>
Tested-by: Frank Nägler <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Frank Nägler <>
Reviewed-by: Anja Leichsenring <>

Revision c529deac (diff)
Added by Harald Atteneder about 1 year ago

[TASK] Keep old value on confirmation modal close

When changing the doktype a confirmation modal appears. This patch
reverts the value of the field to the original value after closing the
modal without clicking OK.

This works for all selects with 'onChange' => 'reload' and
'renderType' => 'selectSingle'

Resolves: #89220
Releases: master,9.5
Change-Id: I6d479f9180d64e8e4c25e96f52e60dca36863fd9
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61809
Tested-by: TYPO3com <>
Tested-by: Sascha Rademacher <>
Tested-by: Tobi Kretschmann <>
Reviewed-by: Sascha Rademacher <>
Reviewed-by: Tobi Kretschmann <>

History

#1 Updated by Riccardo De Contardi about 1 year ago

This seems related #34624

#2 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771

#3 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771

#4 Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771

#5 Updated by Gerrit Code Review about 1 year ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771

#6 Updated by Harald Atteneder about 1 year ago

  • Related to Feature #34624: Changing the type field of a new element should not result in saving added

#7 Updated by Harald Atteneder about 1 year ago

  • % Done changed from 0 to 100

#8 Updated by Gerrit Code Review about 1 year ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771

#9 Updated by Gerrit Code Review about 1 year ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771

#10 Updated by Gerrit Code Review about 1 year ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771

#11 Updated by Gerrit Code Review about 1 year ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771

#12 Updated by Gerrit Code Review about 1 year ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771

#13 Updated by Gerrit Code Review about 1 year ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771

#14 Updated by Gerrit Code Review about 1 year ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61771

#15 Updated by Harald Atteneder about 1 year ago

  • Status changed from Under Review to Resolved

#16 Updated by Gerrit Code Review about 1 year ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61809

#17 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61809

#18 Updated by Harald Atteneder about 1 year ago

  • Status changed from Under Review to Resolved

#19 Updated by Tobi Kretschmann about 1 year ago

  • Status changed from Resolved to Accepted

#20 Updated by Tobi Kretschmann about 1 year ago

  • Related to Feature #89361: Changing 'onChange' => 'reload' behavior added

#21 Updated by Tobi Kretschmann about 1 year ago

Reverted this patch because we need a more general approach to fix this issue.
See: https://forge.typo3.org/issues/89361

#22 Updated by Oliver Hader about 1 year ago

  • Related to Task #89362: Revert changed backend behavior for onChange/type added

#23 Updated by Susanne Moog 7 months ago

  • Status changed from Accepted to Closed

Is now a duplicate of #89361 - see previous comments. Let's continue there.

Also available in: Atom PDF