Project

General

Profile

Actions

Bug #89456

closed

Translations of IRRE Extbase Records in Workspaces not saved

Added by Rainer Becker almost 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2019-10-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Changes in workspaced IRRE relations of extbase tables save in non-default languages.

To reproduce:

  • create Extension with Extensionbuilder
  • create model with a field of type images
  • save and install extension
  • create a record of the new type, reference an image, save and translate it
  • change to a non-live workspace and edit the record
  • edit the record’s image reference attributes (title, alternative text...) in default language and save – works
  • change to a translation, edit the referenced image attributes and save – the changes are not persisted

Tested with TYPO3 8.7.28


Related issues 5 (0 open5 closed)

Related to TYPO3 Core - Bug #88021: Preview of a record related with FAL does not work when file is changed in a workspaceClosed2019-03-27

Actions
Related to TYPO3 Core - Bug #82750: Workspace preview doesn't preview MM relations properlyClosed2017-10-12

Actions
Related to TYPO3 Core - Bug #82086: Frontend Preview Mode And Missing Inline Elements in WorkspaceClosed2017-08-11

Actions
Related to TYPO3 Core - Bug #76993: Getting a single extbase query result in a workspace for a relation that has been deleted and re-added returns no relationClosed2016-07-08

Actions
Related to TYPO3 Core - Task #57169: Invalid relations of MM records in workspacesClosedOliver Hader2014-03-21

Actions
Actions #1

Updated by Benni Mack over 1 year ago

  • Status changed from New to Needs Feedback

Hey, we've improved the situation in v10 LTS and v11 now drastically, can you recheck if this problem still occurs. I think this issue was solved with
https://github.com/typo3/typo3/commit/72cf09912a

Actions #2

Updated by Benni Mack over 1 year ago

  • Related to Bug #88021: Preview of a record related with FAL does not work when file is changed in a workspace added
Actions #3

Updated by Benni Mack over 1 year ago

  • Related to Bug #82750: Workspace preview doesn't preview MM relations properly added
Actions #4

Updated by Benni Mack over 1 year ago

  • Related to Bug #82086: Frontend Preview Mode And Missing Inline Elements in Workspace added
Actions #5

Updated by Benni Mack over 1 year ago

  • Related to Bug #76993: Getting a single extbase query result in a workspace for a relation that has been deleted and re-added returns no relation added
Actions #6

Updated by Benni Mack over 1 year ago

  • Related to Task #57169: Invalid relations of MM records in workspaces added
Actions #7

Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Needs Feedback to Closed

No feedback since 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce this issue, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Actions

Also available in: Atom PDF