Bug #89643

file permissions cannot not both be empty

Added by Robert Wildling about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Miscellaneous
Target version:
-
Start date:
2019-11-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
user groups, permission, file, folder
Complexity:
Is Regression:
Sprint Focus:

Description

When unchecking all options in each folder and file permission settings, they fall back to a standard definition.
Currently it is required to have at least one options checked in one of the to settings (see screenshot).

Since this is a setting that is usually defined by an imported user group, it should be possible to provide an initial settings that turns everything off.


Related issues

Related to TYPO3 Core - Bug #70812: edit user or usergroup > cannot remove every permission on file/directoriesAccepted2015-10-17

Actions
#1

Updated by Riccardo De Contardi almost 2 years ago

  • Related to Bug #70812: edit user or usergroup > cannot remove every permission on file/directories added
#2

Updated by Riccardo De Contardi almost 2 years ago

Is this one the same issue? #70812

#3

Updated by Robert Wildling almost 2 years ago

I would say yes according to the detailed description of that issue.

#4

Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for patchlevel)

Robert Lemke Wilding - I close this issue as a duplicate of #70812; please continue the discussion there. I added your issue as related to keep track of it

If you think that this is the wrong decision please reopen it or ping me. Thank you.

#5

Updated by Robert Wildling almost 2 years ago

Great! Totally fine with that!
Thanks for being such a Sherlock Holmes and uncovering duplicates!
Have a great holiday season!

#6

Updated by Riccardo De Contardi almost 2 years ago

Thank you, too kind - you too.

Also available in: Atom PDF