Bug #89810

Language Packs: Error if mirror download times out

Added by Andreas Fernandez 11 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-11-29
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If the internet connection is pretty bad, downloading language packs isn't possible if downloading the mirrors fails due to a timeout with the following exception:

gzdecode() expects parameter 1 to be string, boolean given


Related issues

Related to TYPO3 Core - Bug #89973: no error if language files can't be loaded Rejected 2019-12-17
Related to TYPO3 Core - Bug #86023: Language Package Update doesn't show an error if update isn't possible due connection problems Closed 2018-08-29

Associated revisions

Revision d93d742f (diff)
Added by Andreas Fernandez 11 months ago

[BUGFIX] Use RequestFactory for downloading mirrors and check response properly

The LanguagePackService now uses the RequestFactory to download the
mirrors.xml.gz file, since it throws proper exceptions on failures.

In case of e.g. a timeout, the thrown exception is properly caught and
the designed fallback kicks in.

Resolves: #89810
Releases: master, 9.5
Change-Id: Ie4e8bcf02c33eb18e58f505f1a791c1233d6f593
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62496
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Tested-by: Richard Haeser <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Richard Haeser <>

Revision 2c48f627 (diff)
Added by Richard Haeser 11 months ago

[BUGFIX] Use RequestFactory for downloading mirrors and check response properly

The LanguagePackService now uses the RequestFactory to download the
mirrors.xml.gz file, since it throws proper exceptions on failures.

In case of e.g. a timeout, the thrown exception is properly caught and
the designed fallback kicks in.

Resolves: #89810
Releases: master, 9.5
Change-Id: Ie4e8bcf02c33eb18e58f505f1a791c1233d6f593
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62462
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Richard Haeser <>
Tested-by: TYPO3com <>
Tested-by: Richard Haeser <>

History

#1 Updated by Gerrit Code Review 11 months ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62496

#2 Updated by Gerrit Code Review 11 months ago

Patch set 1 for branch master of project Teams/Security/TYPO3v4-Core has been pushed to the review server.
It is available at https://review.typo3.org/c/Teams/Security/TYPO3v4-Core/+/62505

#3 Updated by Gerrit Code Review 11 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62496

#4 Updated by Gerrit Code Review 11 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62496

#5 Updated by Gerrit Code Review 11 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62496

#6 Updated by Gerrit Code Review 11 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62496

#7 Updated by Gerrit Code Review 11 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62462

#8 Updated by Andreas Fernandez 11 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Gerrit Code Review 11 months ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62462

#10 Updated by Richard Haeser 11 months ago

  • Status changed from Under Review to Resolved

#11 Updated by Georg Ringer 10 months ago

  • Related to Bug #89973: no error if language files can't be loaded added

#12 Updated by Benni Mack 10 months ago

  • Status changed from Resolved to Closed

#13 Updated by Georg Ringer 8 months ago

  • Related to Bug #86023: Language Package Update doesn't show an error if update isn't possible due connection problems added

Also available in: Atom PDF