Project

General

Profile

Actions

Bug #90009

closed

Installtool gives status 404 when installPassword is not set in LocalConfiguration.php

Added by Richard Vollebregt almost 4 years ago. Updated 12 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Start date:
2019-12-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The installtool gives a 404 status when the installPassword key is not set in the LocalConfiguration file.
An error message regarding the missing key would be more helpful in this case, I think.

Maintenance Middleware won't handle the request when no installtool password is set:
public/typo3/sysext/install/Classes/Middleware/Maintenance.php:242 causing a 404.

Reproducable in version 10.2 and higher.

Actions #1

Updated by Riny van Tiggelen almost 4 years ago

Experienced the same issue, an error message would be helpful.
Would save a lot of time debugging the core.

Actions #2

Updated by Georg Ringer over 3 years ago

  • Target version set to 10 LTS
Actions #3

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63558

Actions #4

Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63558

Actions #5

Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63558

Actions #6

Updated by Georg Ringer over 3 years ago

  • Status changed from Under Review to Rejected

thanks for creating this issue. we tried to fix this but the same code is also used during installing TYPO3 and everything tightly coupled together this won't change in future. copy from gerrit

Problem here is that the middleware is also used for the first install where the requirements are different. No LocalConfiguration and FIRST_INSTALL file required.

This behaviour breaks by throwing the Exceptions, because in this case the information about how to create FIRST_INSTALL should be shown. So it's fine if everything is FALSE in this scenario.

On the other side in the Install Tool (after the first installation) the same scenario should trigger the Exceptions.

So without any evidence in which context we are currently, I see no possibility to throw exceptions here as this would break the first install.

Bit more detailed:

Scenario 1 (First install):
No FIRST_INSTALL, No LocalConfiguration -> Fine, shows "create FIRST_INSTALL"

Scenario 2 (First install):
FIRST_INSTALL file created, No LocalConfiguration -> Fine, starts the install

Scenario 3 (Install tool):
No FIRST_INSTALL, No LocalConfiguration -> Error as LocalConfiguration is required

Scenario 4 (Install tool):
FIRST_INSTALL file created, No LocalConfiguration -> (current behaviour) Fine, starts the install

Please correct me if I misunderstood something, but many different approaches failed in at least one scenario.

therefore I am closing this issue

Actions #7

Updated by Stephan Großberndt about 1 year ago

I just spent a lot of time debugging the TYPO3 Middleware stack, server configuration and lots of other places trying to find out why in the TYPO3 backend all admin tools except "Extensions" only show a blank page and /typo3/install.php as well.

I think it is very unfortunate the very simple piece of information "install tool password is empty" is not delivered to the user.

Actions #8

Updated by Markus Timtner 12 months ago

  • Target version changed from 10 LTS to Candidate for Major Version
  • TYPO3 Version changed from 10 to 11
  • PHP Version changed from 7.2 to 8.1

Can confirm that this is VERY unfortunate -

This is still present in v11 with a fresh DDEV install.

Actions

Also available in: Atom PDF