Project

General

Profile

Actions

Bug #90120

closed

YAML forms are not FAL safe

Added by Christian Eßl over 4 years ago. Updated 1 day ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2020-01-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:
Remote Sprint

Description

If you change the location of a file inside TYPO3, you would usually expect that the file abstraction layer will internally handle the changes, so the file can still be accessed from the frontend. (no hard-wired paths to the original file location)

This is not the case, if you change the location of a YAML form. If you go to the filelist and change the location of a yaml form, frontend pages that are using this form in a plugin will now break, because the forms location can't be resolved anymore.
I suppose this is because of the flexform configuration of the form plugin. - The flexform saves the original file location to the yaml instead of utilizing FAL.

Actions #1

Updated by Björn Jacob about 4 years ago

  • Sprint Focus set to Remote Sprint
Actions #2

Updated by Björn Jacob almost 3 years ago

  • TYPO3 Version changed from 10 to 11
  • Sprint Focus deleted (Remote Sprint)

Hint: Form definitions cannot be accessed anymore via "filelist". Have to check, how to proceed with this issue.

Actions #3

Updated by Björn Jacob almost 3 years ago

  • Sprint Focus set to Remote Sprint
Actions #4

Updated by Georg Ringer 1 day ago

  • Status changed from New to Closed

as the form files can't be accessed via filelist, I am closing this issue

Actions

Also available in: Atom PDF